aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/apron/apron-0.9.10-r1.ebuild')
-rw-r--r--sci-mathematics/apron/apron-0.9.10-r1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/sci-mathematics/apron/apron-0.9.10-r1.ebuild b/sci-mathematics/apron/apron-0.9.10-r1.ebuild
index 6cc45621d..41e9acf26 100644
--- a/sci-mathematics/apron/apron-0.9.10-r1.ebuild
+++ b/sci-mathematics/apron/apron-0.9.10-r1.ebuild
@@ -31,8 +31,8 @@ src_prepare() {
sed -i Makefile.config \
-e "s/FLAGS = \\\/FLAGS += \\\/g" \
-e "s/-O3 -DNDEBUG/-DNDEBUG/g" \
- -e "s/APRON_PREFIX =.*/APRON_PREFIX = \${DESTDIR}\/usr/g" \
- -e "s/MLGMPIDL_PREFIX =.*/MLGMPIDL_PREFIX = \${DESTDIR}\/usr/g"
+ -e "s/APRON_PREFIX =.*/APRON_PREFIX = \$(DESTDIR)\/usr/g" \
+ -e "s/MLGMPIDL_PREFIX =.*/MLGMPIDL_PREFIX = \$(DESTDIR)\/usr/g"
#fix doc building process
sed -i Makefile -e "s/; make html/; make/g"
@@ -42,9 +42,6 @@ src_prepare() {
-e "s/OUTPUT_DIRECTORY = \/.*/OUTPUT_DIRECTORY = .\//g" \
-e "s/STRIP_FROM_PATH = \/.*/STRIP_FROM_PATH = .\//g"
- #fix ppl install for 32 platforms
- sed -i ppl/Makefile -e "s/libap_ppl_caml\*\./libap_ppl\*\./g"
-
if [[ "$(gcc-major-version)" == "4" ]]; then
sed -i -e "s/# HAS_LONG_DOUBLE = 1/HAS_LONG_DOUBLE = 1/g" Makefile.config
fi
@@ -58,7 +55,7 @@ src_compile() {
}
src_install(){
- DESTDIR="${D}" emake install || die "emake install failed"
+ emake install DESTDIR="${D}" || die "emake install failed"
dodoc AUTHORS Changes README
if use doc; then