aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/cipi/cipi-1.0.ebuild')
-rw-r--r--sci-mathematics/cipi/cipi-1.0.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sci-mathematics/cipi/cipi-1.0.ebuild b/sci-mathematics/cipi/cipi-1.0.ebuild
index ca0bc1afe..126bed614 100644
--- a/sci-mathematics/cipi/cipi-1.0.ebuild
+++ b/sci-mathematics/cipi/cipi-1.0.ebuild
@@ -1,26 +1,30 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=4
inherit cmake-utils git
-DESCRIPTION="cipi is computing information projections iteratively"
+DESCRIPTION="Computing information projections iteratively"
HOMEPAGE="http://github.com/tom111/cipi"
EGIT_REPO_URI="git://github.com/tom111/cipi.git"
EGIT_COMMIT="${PV}"
-CMAKE_IN_SOURCE_BUILD="yes"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="doc"
-DEPEND="dev-libs/boost
- doc? ( virtual/latex-base )"
+DEPEND="
+ dev-libs/boost
+ doc? ( virtual/latex-base )"
+RDEPEND="${DEPEND}"
DOCS="AUTHORS README"
+CMAKE_IN_SOURCE_BUILD="yes"
+
src_configure() {
mycmakeargs=(
$(cmake-utils_use_enable doc)
@@ -30,10 +34,10 @@ src_configure() {
}
pkg_postinst() {
- elog " "
+ echo ""
elog "The sample PARAM file has been installed to /usr/share/${PN}-${PV}"
- elog " "
+ echo ""
if use doc; then
elog "A pdf manual has been installed to /usr/share/${PN}-${PV}"
fi
-} \ No newline at end of file
+}