aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gappa/gappa-1.1.1.ebuild')
-rw-r--r--sci-mathematics/gappa/gappa-1.1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-mathematics/gappa/gappa-1.1.1.ebuild b/sci-mathematics/gappa/gappa-1.1.1.ebuild
new file mode 100644
index 000000000..a817cbbd2
--- /dev/null
+++ b/sci-mathematics/gappa/gappa-1.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+DESCRIPTION="A tool to help verifying and proving properties on floating-point or fixed-point arithmetic"
+HOMEPAGE="http://gappa.gforge.inria.fr/"
+SRC_URI="http://gforge.inria.fr/frs/download.php/33486/${P}.tar.gz"
+
+LICENSE="|| ( CeCILL-2.0 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/gmp
+ dev-libs/mpfr
+ dev-libs/boost"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i Remakefile.in \
+ -e "s:mkdir -p @bindir@:mkdir -p \$(DESTDIR)@bindir@:g" \
+ -e "s:cp src/gappa @bindir@:cp src/gappa \$(DESTDIR)@bindir@:g"
+}
+
+src_compile() {
+ ./remake || die "emake failed"
+ if use doc; then
+ ./remake doc/html/index.html
+ fi
+}
+
+src_install() {
+ DESTDIR="${D}" ./remake install || die "emake install failed"
+ dodoc NEWS README AUTHORS ChangeLog
+ if use doc; then
+ dohtml -A png -r doc/html/*
+ fi
+}
+