aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/wxmaxima/wxmaxima-0.6.5.ebuild')
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-0.6.5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/wxmaxima-0.6.5.ebuild b/sci-mathematics/wxmaxima/wxmaxima-0.6.5.ebuild
new file mode 100644
index 000000000..55cc16210
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-0.6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils autotools
+
+MYP=wxMaxima-${PV}
+
+DESCRIPTION="A Graphical frontend to Maxima, using the wxWidgets toolkit."
+HOMEPAGE="http://wxmaxima.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static doc"
+
+DEPEND=">=dev-libs/libxml2-2.5.0
+ >=x11-libs/wxGTK-2.6"
+RDEPEND=">=sci-mathematics/maxima-5.9.1"
+
+S=${WORKDIR}/${MYP}
+
+src_unpack () {
+ unpack ${A}
+
+ sed 's|#PF#|'${PF}'|g' \
+ ${FILESDIR}/${PF}-docfiles.patch > ${PF}-docfiles.patch
+
+ epatch ${PF}-docfiles.patch
+
+ cd ${S}
+ einfo "Regenerating autotools files..."
+ eautomake || die "eautomake failed"
+}
+
+
+src_compile () {
+ econf $(use_enable static static-wx) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "make install failed"
+ insinto /usr/share/pixmaps/
+ doins maxima-new.png
+ make_desktop_entry wxmaxima wxMaxima maxima-new
+
+ cd ${S}/data
+
+ if use doc; then
+ insinto "/usr/share/doc/${PF}"
+ doins docs.zip intro.zip
+ fi
+}