aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/z3/ChangeLog10
-rw-r--r--sci-mathematics/z3/Manifest1
-rw-r--r--sci-mathematics/z3/metadata.xml5
-rw-r--r--sci-mathematics/z3/z3-4.3.1.ebuild75
-rw-r--r--sci-mathematics/z3/z3-9999.ebuild81
5 files changed, 172 insertions, 0 deletions
diff --git a/sci-mathematics/z3/ChangeLog b/sci-mathematics/z3/ChangeLog
new file mode 100644
index 000000000..a078c2ad6
--- /dev/null
+++ b/sci-mathematics/z3/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/z3
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 02 Dec 2013; Justin Lecher <jlec@gentoo.org> z3-4.3.1.ebuild, z3-9999.ebuild,
+ +metadata.xml:
+ Make build verbose; respect CXX, CXXFLAGS, LDFLAGS; use EPYTHON instead of a
+ direct python call; check for openmp compatibility of the c++ compiler; add
+ USE=gmp; drop unnecessary eclass; add missing metadata.xml
+
diff --git a/sci-mathematics/z3/Manifest b/sci-mathematics/z3/Manifest
new file mode 100644
index 000000000..109db81fd
--- /dev/null
+++ b/sci-mathematics/z3/Manifest
@@ -0,0 +1 @@
+DIST z3-4.3.1.tar.xz 1841796 SHA256 db36d7c96e506a08c3a7967340983edb298dcb0d33be5dab064c36f4e9cf6ee8 SHA512 ccffb07c6468911685db28030e012a6504c2ce5d50b33163cfac0f12bdbd25b5365b39e61ad514ede01bc138cbc7004de6a9efa6264bc5d2f9fc8db63c989c91 WHIRLPOOL 30fac04a772a5fee2d8d468f7620d858374578561da0aba5971e09f95713fb275c6695b8c1bb5a8c01c3781d7db65423d3d194a52ea398b423e90198a4ce22b5
diff --git a/sci-mathematics/z3/metadata.xml b/sci-mathematics/z3/metadata.xml
new file mode 100644
index 000000000..897aa2e6b
--- /dev/null
+++ b/sci-mathematics/z3/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-mathematics/z3/z3-4.3.1.ebuild b/sci-mathematics/z3/z3-4.3.1.ebuild
new file mode 100644
index 000000000..adf4f6eda
--- /dev/null
+++ b/sci-mathematics/z3/z3-4.3.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools flag-o-matic python-r1 toolchain-funcs vcs-snapshot
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="http://z3.codeplex.com/"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="MSR-LA"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(tc-getCXX)$ == *g++* ]] && ! tc-has-openmp; then
+ ewarn "Please use an openmp compatible compiler"
+ ewarn "like >gcc-4.2 with USE=openmp"
+ die "Openmp support missing in compiler"
+ fi
+ fi
+}
+
+src_prepare() {
+ sed \
+ -e 's:-O3::g' \
+ -e 's:-fomit-frame-pointer::' \
+ -e 's:-msse2::g' \
+ -e 's:-msse::g' \
+ -e "/LINK_EXTRA_FLAGS/s:@LDFLAGS@:-lrt $(usex gmp -lgmp):g" \
+ -e 's:t@\$:t\$:g' \
+ -i scripts/*mk* || die
+
+ append-ldflags -fopenmp
+
+ eautoreconf
+}
+
+src_configure() {
+ python_export_best
+ econf \
+ --host="" \
+ --with-python="${PYTHON}" \
+ $(use_with gmp) \
+ SLIBFLAGS=" -Wl,-soname,lib${PN}.so.0.1 "
+ ${EPYTHON} scripts/mk_make.py || die
+}
+
+src_compile() {
+ emake \
+ --directory="build" \
+ CXX=$(tc-getCXX) \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ LINK_FLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ doheader src/api/z3*.h src/api/c++/z3*.h
+ dolib.so build/*.so
+ dobin build/z3
+
+ python_foreach_impl python_domodule src/api/python/*.py
+}
diff --git a/sci-mathematics/z3/z3-9999.ebuild b/sci-mathematics/z3/z3-9999.ebuild
new file mode 100644
index 000000000..15c338b4f
--- /dev/null
+++ b/sci-mathematics/z3/z3-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools flag-o-matic git-r3 python-r1 toolchain-funcs
+
+DESCRIPTION="An efficient theorem prover"
+HOMEPAGE="http://z3.codeplex.com/"
+SRC_URI=""
+EGIT_REPO_URI="https://git01.codeplex.com/z3"
+
+SLOT="0"
+LICENSE="MSR-LA"
+KEYWORDS=""
+IUSE="gmp"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ gmp? ( dev-libs/gmp )"
+# A new curl is needed because codeplex has a bug and early version of libcurl
+# will cause a failed git clone.
+DEPEND="${RDEPEND}
+ >=net-misc/curl-7.33"
+
+EGIT_NONSHALLOW=1
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if [[ $(tc-getCXX)$ == *g++* ]] && ! tc-has-openmp; then
+ ewarn "Please use an openmp compatible compiler"
+ ewarn "like >gcc-4.2 with USE=openmp"
+ die "Openmp support missing in compiler"
+ fi
+ fi
+}
+
+src_prepare() {
+ sed \
+ -e 's:-O3::g' \
+ -e 's:-fomit-frame-pointer::' \
+ -e 's:-msse2::g' \
+ -e 's:-msse::g' \
+ -e "/LINK_EXTRA_FLAGS/s:@LDFLAGS@:-lrt $(usex gmp -lgmp):g" \
+ -e 's:t@\$:t\$:g' \
+ -i scripts/*mk* || die
+
+ append-ldflags -fopenmp
+
+ eautoreconf
+}
+
+src_configure() {
+ python_export_best
+ econf \
+ --host="" \
+ --with-python="${PYTHON}" \
+ $(use_with gmp) \
+ SLIBFLAGS=" -Wl,-soname,lib${PN}.so.0.1 "
+ ${EPYTHON} scripts/mk_make.py || die
+}
+
+src_compile() {
+ emake \
+ --directory="build" \
+ CXX=$(tc-getCXX) \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ LINK_FLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ doheader src/api/z3*.h src/api/c++/z3*.h
+ dolib.so build/*.so
+ dobin build/z3
+
+ python_foreach_impl python_domodule src/api/python/*.py
+}