aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/Manifest2
-rw-r--r--sci-mathematics/maxima/maxima-5.9.2.ebuild14
2 files changed, 9 insertions, 7 deletions
diff --git a/sci-mathematics/maxima/Manifest b/sci-mathematics/maxima/Manifest
index b9188c056..7961ff95a 100644
--- a/sci-mathematics/maxima/Manifest
+++ b/sci-mathematics/maxima/Manifest
@@ -2,4 +2,4 @@ MD5 34088e52192b29787ef45aa41a483be9 ChangeLog 5013
MD5 6957a9bafd71a24b58e148bb2ee58257 files/50maxima-gentoo.el 346
MD5 f94d8f9a9d0bf93b5f28b15f6198261e files/digest-maxima-5.9.2 65
MD5 7a31ee68476b8dfb009b4b917b4e4e4c files/maxima-5.9.2-unicode-fix.patch 2738
-MD5 2a3e3dd585f61aa9dd2f3b3e354d6e11 maxima-5.9.2.ebuild 2567
+MD5 ed4958c6740290c2719c451bc15958c8 maxima-5.9.2.ebuild 2668
diff --git a/sci-mathematics/maxima/maxima-5.9.2.ebuild b/sci-mathematics/maxima/maxima-5.9.2.ebuild
index 8abd88f0e..1feb233d4 100644
--- a/sci-mathematics/maxima/maxima-5.9.2.ebuild
+++ b/sci-mathematics/maxima/maxima-5.9.2.ebuild
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2 AECA"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~sparc"
-IUSE="cmucl clisp sbcl tetex emacs auctex tcltk rlwrap"
+IUSE="cmucl clisp sbcl tetex emacs auctex tcltk"
DEPEND="tetex? ( virtual/tetex )
emacs? ( virtual/emacs )
@@ -20,10 +20,12 @@ DEPEND="tetex? ( virtual/tetex )
!clisp? ( !sbcl? ( !cmucl? ( >=dev-lisp/gcl-2.6.7 ) ) )
cmucl? ( >=dev-lisp/cmucl-19a )
clisp? ( >=dev-lisp/clisp-2.33.2-r1 )
- sbcl? ( >=dev-lisp/sbcl-0.8.14 )"
-RDEPEND="rlwrap? app-misc/rlwrap
- tcktk? >=dev-lang/tk-8.3.3
- >=media-gfx/gnuplot-4.0-r1"
+ sbcl? ( >=dev-lisp/sbcl-0.9.4 )"
+# rlwrap is actually recommanded for clisp and sbcl
+RDEPEND=">=media-gfx/gnuplot-4.0
+ cmucl? ( app-misc/rlwrap )
+ sbcl? ( app-misc/rlwrap )
+ tcktk? ( >=dev-lang/tk-8.3.3 )"
src_unpack() {
unpack ${A}
@@ -41,7 +43,7 @@ src_compile() {
# remove xmaxima and rmaxima if not requested
use tcltk || sed -i -e '/^SUBDIRS/s/xmaxima//' interfaces/Makefile.in
- use rlwrap || sed -i -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' src/Makefile.in
+ (! use sbcl && ! use cmucl) || sed -i -e '/^@WIN32_FALSE@bin_SCRIPTS/s/rmaxima//' src/Makefile.in
local myconf=""
if use cmucl || use clisp || use sbcl; then