aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-front/files')
-rw-r--r--sci-misc/elmer-front/files/elmer-front-6.0_p4651-out-of-source.patch30
-rw-r--r--sci-misc/elmer-front/files/elmer-front-6.0_p4651-tcltk8.6.patch55
-rw-r--r--sci-misc/elmer-front/files/elmer-front-6.0_p4651-underlinking.patch16
-rw-r--r--sci-misc/elmer-front/files/elmer-front-Makefile-install.patch18
4 files changed, 0 insertions, 119 deletions
diff --git a/sci-misc/elmer-front/files/elmer-front-6.0_p4651-out-of-source.patch b/sci-misc/elmer-front/files/elmer-front-6.0_p4651-out-of-source.patch
deleted file mode 100644
index 872c03f21..000000000
--- a/sci-misc/elmer-front/files/elmer-front-6.0_p4651-out-of-source.patch
+++ /dev/null
@@ -1,30 +0,0 @@
- src/Makefile.am | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-old mode 100755
-new mode 100644
-index 894a547..dc7c77b
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -87,15 +87,16 @@ endif
- ElmerFront_LDADD = -lX11
-
- install-data-local:
-- @echo "Installing tcl scripts to ${prefix}/share/elmerfront/tcl"
-+ @echo "Installing tcl scripts to ${DESTDIR}${prefix}/share/elmerfront/tcl"
-
- mkdir -p "$(DESTDIR)${prefix}/share/elmerfront/tcl"
-- cp -r ./tcl/* "$(DESTDIR)${prefix}/share/elmerfront/tcl"
-+ cp -r "${srcdir}"/tcl/* "$(DESTDIR)${prefix}/share/elmerfront/tcl"
-+ cp -r "${builddir}"/tcl/* "$(DESTDIR)${prefix}/share/elmerfront/tcl"
- rm -rf `find $(DESTDIR)$(prefix)/share/elmerfront/tcl -name .svn`
-
-- @echo "Installing *.edf *.rgb to ${prefix}/share/elmerfront/lib"
-+ @echo "Installing *.edf *.rgb to ${DESTDIR}${prefix}/share/elmerfront/lib"
- mkdir -p "$(DESTDIR)${prefix}/share/elmerfront/lib"
-- cp -r ./lib/* "$(DESTDIR)${prefix}/share/elmerfront/lib"
-+ cp -r "${srcdir}"/lib/* "$(DESTDIR)${prefix}/share/elmerfront/lib"
- rm -rf `find $(DESTDIR)$(prefix)/share/elmerfront/lib -name .svn`
-
-
diff --git a/sci-misc/elmer-front/files/elmer-front-6.0_p4651-tcltk8.6.patch b/sci-misc/elmer-front/files/elmer-front-6.0_p4651-tcltk8.6.patch
deleted file mode 100644
index 7fa7605b7..000000000
--- a/sci-misc/elmer-front/files/elmer-front-6.0_p4651-tcltk8.6.patch
+++ /dev/null
@@ -1,55 +0,0 @@
- src/ecif_userinterface_TCL.cpp | 18 +++++++++++++++++-
- 1 file changed, 17 insertions(+), 1 deletion(-)
-
-diff --git a/src/ecif_userinterface_TCL.cpp b/src/ecif_userinterface_TCL.cpp
-index 7f581a8..53e0432 100644
---- a/src/ecif_userinterface_TCL.cpp
-+++ b/src/ecif_userinterface_TCL.cpp
-@@ -622,7 +622,11 @@ UserInterface_TCL::createTclEnvironment(Hinst application)
-
- // *** Invoke application-specific initialization.
- if (My_Tcl_AppInit(interp) != TCL_OK) {
-+#if TCL_MAJOR_VERSION <=8 && TCL_MINOR_VERSION < 6
- WishPanic("My_Tcl_AppInit failed: %s\n", interp->result);
-+#else
-+ WishPanic("My_Tcl_AppInit failed: %s\n", Tcl_GetStringResult(interp));
-+#endif
- }
-
- // Result value is the Tcl interpreter
-@@ -4685,11 +4689,19 @@ UserInterface_TCL::sendCommandToGui(Tcl_Interp* interp, const char* cmd, const c
- Tcl_DStringFree( &dstring );
- }
-
-+#if TCL_MAJOR_VERSION <=8 && TCL_MINOR_VERSION < 6
- if (interp->result[0] != '\0') {
-+#else
-+ if (Tcl_GetStringResult(interp)[0] != '\0') {
-+#endif
-
- char err_buf[256];
- err_buf[255] = '\0';
-+#if TCL_MAJOR_VERSION <=8 && TCL_MINOR_VERSION < 6
- strncpy(err_buf, interp->result, 255);
-+#else
-+ strncpy(err_buf, Tcl_GetStringResult(interp), 255);
-+#endif
-
- char cmd_buf[256];
- cmd_buf[255] = '\0';
-@@ -5350,10 +5362,14 @@ UserInterface_TCL::start(int argc, char** argv)
- //--If we can't load the script (= start CONTROL-SIDE interpreter)
- if (code != TCL_OK) {
-
-- char* p = (char *)Tcl_GetVar(theInterp, "errorInfo", glob_flag);
-+ const char* p = (const char *)Tcl_GetVar(theInterp, "errorInfo", glob_flag);
-
- if ((p == NULL) || (*p == '\0')) {
-+#if TCL_MAJOR_VERSION <=8 && TCL_MINOR_VERSION < 6
- p = theInterp->result;
-+#else
-+ p = Tcl_GetStringResult(theInterp);
-+#endif
- }
-
- ((ofstream*)debugFile)->open("ElmerFront.log", ios::out);
diff --git a/sci-misc/elmer-front/files/elmer-front-6.0_p4651-underlinking.patch b/sci-misc/elmer-front/files/elmer-front-6.0_p4651-underlinking.patch
deleted file mode 100644
index b370ed494..000000000
--- a/sci-misc/elmer-front/files/elmer-front-6.0_p4651-underlinking.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- src/Makefile.am | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 01e3e48..894a547 100755
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -84,6 +84,8 @@ ElmerFront_SOURCES = $(COMMON_SRCS)
-
- endif
-
-+ElmerFront_LDADD = -lX11
-+
- install-data-local:
- @echo "Installing tcl scripts to ${prefix}/share/elmerfront/tcl"
-
diff --git a/sci-misc/elmer-front/files/elmer-front-Makefile-install.patch b/sci-misc/elmer-front/files/elmer-front-Makefile-install.patch
deleted file mode 100644
index 6ecbe6f8e..000000000
--- a/sci-misc/elmer-front/files/elmer-front-Makefile-install.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- front/src/Makefile.am.old 2012-11-12 13:25:34.331046988 +0100
-+++ front/src/Makefile.am 2012-11-12 13:27:36.055100527 +0100
-@@ -85,13 +85,13 @@
- endif
-
- install-data-local:
-- @echo "Installing tcl scripts to ${prefix}/share/elmerfront/tcl"
-+ @echo "Installing tcl scripts to ${DESTDIR}${prefix}/share/elmerfront/tcl"
-
- mkdir -p "$(DESTDIR)${prefix}/share/elmerfront/tcl"
- cp -r ./tcl/* "$(DESTDIR)${prefix}/share/elmerfront/tcl"
- rm -rf `find $(DESTDIR)$(prefix)/share/elmerfront/tcl -name .svn`
-
-- @echo "Installing *.edf *.rgb to ${prefix}/share/elmerfront/lib"
-+ @echo "Installing *.edf *.rgb to ${DESTDIR}${prefix}/share/elmerfront/lib"
- mkdir -p "$(DESTDIR)${prefix}/share/elmerfront/lib"
- cp -r ./lib/* "$(DESTDIR)${prefix}/share/elmerfront/lib"
- rm -rf `find $(DESTDIR)$(prefix)/share/elmerfront/lib -name .svn`