aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-front')
-rw-r--r--sci-misc/elmer-front/Manifest4
-rw-r--r--sci-misc/elmer-front/elmer-front-5.4.1-r1.ebuild56
-rw-r--r--sci-misc/elmer-front/elmer-front-9999.ebuild54
-rw-r--r--sci-misc/elmer-front/files/elmer-front-Makefile-install.patch18
4 files changed, 132 insertions, 0 deletions
diff --git a/sci-misc/elmer-front/Manifest b/sci-misc/elmer-front/Manifest
new file mode 100644
index 000000000..ec4960db6
--- /dev/null
+++ b/sci-misc/elmer-front/Manifest
@@ -0,0 +1,4 @@
+AUX elmer-front-Makefile-install.patch 832 SHA256 d64a6ba001980d47028cf89ab338a9f64e164c083d608704b68a8bdc0a9cac3e SHA512 3d231068263892e095a1a34686ba7a649441bf4267107169a445950c3c9e9db76f51e26259d4c0736229ae97c73af7bd08abcbb44ae779caf004d7f7e4f9b504 WHIRLPOOL 6625d0bc98fdfdc664ee8ccf16444a94d2032bf965fd7d9d563fe3cf6af8670c0d913d0872e848a5daa1eb7a331f54a2925088d037a94342c31d57b0b708ce12
+DIST elmer-front-5.4.1.tar.gz 1451796 SHA256 b9f514626b3e55e8bf3610f6b0c06b05a5f54b23cf4cd48461e724ce019737e4 SHA512 c52d768526cf74f734bb52715204ebabc8dc3c1e65c74f208ddbe0eb58a9439797cfd113585033ffda266f7546970aff1585628f2d5859e789f18e69e5981a7d WHIRLPOOL a8391d235ec7cf63467e5eab5b36012cffd029a2fa0d7ec8575122a2fdff4125dab28d53551730c168a3ffcd593940f2e70874c592c45d98a4b015800078a5e0
+EBUILD elmer-front-5.4.1-r1.ebuild 1304 SHA256 4e22bc18abf04352f1d093c5eff55ea3b0918950338fe5c0d2b57e4c32342e47 SHA512 b16c83fd1658ae5dee820d413eaca2cec8ccf43b8202e4f527d883a3ff990a4505722a90e080d120d29688250aac0a5d0b86c3decf97b9c67e4e1fd6347bff9b WHIRLPOOL 6669fd6262fb732ab16e0ef22a72568982a3da957fb3d1b9ac0023c3ad5ebc18a977b67ee12d2a10e260f3addcdab6ef2d2d8adf0c8b6f9956ba8609a1431868
+EBUILD elmer-front-9999.ebuild 1321 SHA256 55f43b9fab9fe5920c2d9b3e1061e62c42d419375e904dd2cd9ebce034e7ecd5 SHA512 7d44825549c2b2b4e04e311dce47e9a886fd22e211e7358c1fcffdcc4f8f7a4bb60743e66026850ea74a61a307af701ba5341e9a38136c927376d24595bc76a4 WHIRLPOOL 3f268ac8b817c299839aec03525bc6cdff1c9e1118f854310a877f0dbcc5d16ea9c1da31d2bd691f4d8c9a3b7e7337b3df1274a918fdd5dd50f45d7ca59e260b
diff --git a/sci-misc/elmer-front/elmer-front-5.4.1-r1.ebuild b/sci-misc/elmer-front/elmer-front-5.4.1-r1.ebuild
new file mode 100644
index 000000000..b2b98f728
--- /dev/null
+++ b/sci-misc/elmer-front/elmer-front-5.4.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools eutils
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, elmer frontend"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X debug"
+DEPEND="=dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ sci-libs/matc
+ sci-libs/elmer-eio
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PV}/front"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # configure must be executable
+ chmod +x configure
+ epatch ${FILESDIR}/elmer-front-Makefile-install.patch
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}"
+ local myconf
+ export FC="gfortran"
+ export F77="gfortran"
+ myconf="${myconf} --with-eioc --with-matc --with-tcltk"
+ use debug &&
+ myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --without-debug"
+ econf $myconf \
+ $(use_with X x) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/sci-misc/elmer-front/elmer-front-9999.ebuild b/sci-misc/elmer-front/elmer-front-9999.ebuild
new file mode 100644
index 000000000..054841075
--- /dev/null
+++ b/sci-misc/elmer-front/elmer-front-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools eutils subversion
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, elmer frontend"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
+SRC_URI=""
+RESTRICT="mirror"
+ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
+ESVN_PROJECT="${MY_PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X debug"
+DEPEND="dev-lang/tcl
+ dev-lang/tk
+ sci-libs/matc
+ sci-libs/elmer-eio
+ virtual/opengl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PV}/front"
+
+src_prepare() {
+ #unpack ${A}
+ cd "${S}"
+ # configure must be executable
+ #chmod +x configure
+ epatch ${FILESDIR}/elmer-front-Makefile-install.patch
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"
+ local myconf
+ export FC="gfortran"
+ export F77="gfortran"
+ myconf="${myconf} --with-eioc --with-matc --with-tcltk"
+ use debug &&
+ myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --without-debug"
+ econf $myconf \
+ $(use_with X x) \
+ || die "econf failed"
+}
diff --git a/sci-misc/elmer-front/files/elmer-front-Makefile-install.patch b/sci-misc/elmer-front/files/elmer-front-Makefile-install.patch
new file mode 100644
index 000000000..6ecbe6f8e
--- /dev/null
+++ b/sci-misc/elmer-front/files/elmer-front-Makefile-install.patch
@@ -0,0 +1,18 @@
+--- front/src/Makefile.am.old 2012-11-12 13:25:34.331046988 +0100
++++ front/src/Makefile.am 2012-11-12 13:27:36.055100527 +0100
+@@ -85,13 +85,13 @@
+ endif
+
+ install-data-local:
+- @echo "Installing tcl scripts to ${prefix}/share/elmerfront/tcl"
++ @echo "Installing tcl scripts to ${DESTDIR}${prefix}/share/elmerfront/tcl"
+
+ mkdir -p "$(DESTDIR)${prefix}/share/elmerfront/tcl"
+ cp -r ./tcl/* "$(DESTDIR)${prefix}/share/elmerfront/tcl"
+ rm -rf `find $(DESTDIR)$(prefix)/share/elmerfront/tcl -name .svn`
+
+- @echo "Installing *.edf *.rgb to ${prefix}/share/elmerfront/lib"
++ @echo "Installing *.edf *.rgb to ${DESTDIR}${prefix}/share/elmerfront/lib"
+ mkdir -p "$(DESTDIR)${prefix}/share/elmerfront/lib"
+ cp -r ./lib/* "$(DESTDIR)${prefix}/share/elmerfront/lib"
+ rm -rf `find $(DESTDIR)$(prefix)/share/elmerfront/lib -name .svn`