aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-meshgen2d/elmer-meshgen2d-5.4.1-r1.ebuild')
-rw-r--r--sci-misc/elmer-meshgen2d/elmer-meshgen2d-5.4.1-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sci-misc/elmer-meshgen2d/elmer-meshgen2d-5.4.1-r1.ebuild b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-5.4.1-r1.ebuild
deleted file mode 100644
index 66f721078..000000000
--- a/sci-misc/elmer-meshgen2d/elmer-meshgen2d-5.4.1-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-
-inherit autotools eutils
-
-ELMER_ROOT="elmerfem"
-MY_PN=${PN/elmer-/}
-
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, meshgen2d"
-HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
-RESTRICT="mirror"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="debug"
-DEPEND="sys-libs/glibc"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${PV}/meshgen2d"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # configure must be executable
- chmod +x configure
- eautoreconf
-}
-
-src_compile() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- econf $myconf || die "econf failed"
- emake || die "emake failed"
-}
-
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}