aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild')
-rw-r--r--sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild41
1 files changed, 18 insertions, 23 deletions
diff --git a/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild
index fafab98be..e2cd9480d 100644
--- a/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild
+++ b/sci-misc/elmer-meshgen2d/elmer-meshgen2d-9999.ebuild
@@ -1,46 +1,41 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=5
-inherit autotools eutils subversion
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils subversion
ELMER_ROOT="elmerfem"
MY_PN=${PN/elmer-/}
-DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, meshgen2d"
+DESCRIPTION="Finite element programs, libraries, and visualization tools - meshgen2d"
HOMEPAGE="http://www.csc.fi/english/pages/elmer"
-#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
SRC_URI=""
-RESTRICT="mirror"
ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
ESVN_PROJECT="${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-DEPEND="sys-libs/glibc"
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${PV}/meshgen2d"
+S="${WORKDIR}/meshgen2d"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0_p4651-oof.patch
+)
src_prepare() {
- #unpack ${A}
- cd "${S}"
- # configure must be executable
- #chmod +x configure
- eautoreconf
+ subversion_src_prepare
+ autotools-utils_src_prepare
}
src_configure() {
- cd "${S}"
- local myconf
- export FC="gfortran"
- export F77="gfortran"
- use debug &&
- myconf="${myconf} --with-debug" ||
- myconf="${myconf} --without-debug"
- econf $myconf || die "econf failed"
+ local myeconfargs=(
+ $(use_with debug)
+ )
+ autotools-utils_src_configure
}