aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/elmer-post')
-rw-r--r--sci-misc/elmer-post/Manifest3
-rw-r--r--sci-misc/elmer-post/elmer-post-5.4.1-r1.ebuild56
-rw-r--r--sci-misc/elmer-post/elmer-post-9999.ebuild58
3 files changed, 117 insertions, 0 deletions
diff --git a/sci-misc/elmer-post/Manifest b/sci-misc/elmer-post/Manifest
new file mode 100644
index 000000000..02d085523
--- /dev/null
+++ b/sci-misc/elmer-post/Manifest
@@ -0,0 +1,3 @@
+DIST elmer-post-5.4.1.tar.gz 5211292 SHA256 4df38f81937f5357f6e9ca6708ae820e1e6119c9379222e0bff10435e26dc19d SHA512 29450b72245265fca0e4ff83307e2ae189ff506b32b6ee706367fe303d430095faba475f98d8bd6eda1e4d8688e81aa0552366905acc09d0e58de9c27a35eafc WHIRLPOOL e386498bc56611a3680e5c80db55097ce40b107700c447b4d9abb554b7ebd6ab35d324c83d570ccea7f7497d5d41e5496ea526f9e5829177a092401da1f8140f
+EBUILD elmer-post-5.4.1-r1.ebuild 1347 SHA256 ba3c9357654ff597e501f1938de839d9faf00bcc77d905f6ed8ca5028727b458 SHA512 73f57b079420a8b215700a8b9c3f812101f152ad64a06220d3ce1ae4619a28288bc7ee8b22042ea887b5c232c4237c5e57404bc91cad2bf84bcc2dcc464cdea7 WHIRLPOOL 8a91e631da5a8c9e9590c50ab685ab3c15736ed10d59914571156e5f6ce18b264700366ef9e8aa7cf16d512dfc874be5eb405fba7040f75acfd1d9035812935b
+EBUILD elmer-post-9999.ebuild 1438 SHA256 81d8ef803f36a607c7a2cc92e92535537e5b60d58140911639b25a181607ed32 SHA512 4fc05fe713120f954d69798c0bad1825ea5007686ace0bed939f4d3365ba58784f1c366e77e99061e6887b17c9c924870dc0d7938c53c11412ea670c43829483 WHIRLPOOL 4d57260192c4f45b3b5a232b28a2944501e3a89a96b3e0bad5d03e74a66377e13d7bf864c6c69b359ba50ac4b57ac941bd3d161ecb617af48fdfeec8e1738a2f
diff --git a/sci-misc/elmer-post/elmer-post-5.4.1-r1.ebuild b/sci-misc/elmer-post/elmer-post-5.4.1-r1.ebuild
new file mode 100644
index 000000000..459f6ce65
--- /dev/null
+++ b/sci-misc/elmer-post/elmer-post-5.4.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools eutils flag-o-matic
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, elmerpost"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl X debug"
+DEPEND="=dev-lang/tcl-8.4*
+ =dev-lang/tk-8.4*
+ opengl? ( virtual/opengl
+ media-libs/ftgl )
+ sci-libs/matc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PV}/post"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # configure must be executable
+ chmod +x configure
+ eautoreconf
+}
+
+src_compile() {
+ cd "${S}"
+ local myconf
+ export FC="gfortran"
+ export F77="gfortran"
+ myconf="${myconf} --with-matc"
+ use opengl && append-cppflags -I/usr/include/FTGL
+ use debug &&
+ myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --without-debug"
+ econf $myconf \
+ $(use_with X x) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake ELMER_POST_DATADIR="${D}/usr/share/elmerpost" DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/sci-misc/elmer-post/elmer-post-9999.ebuild b/sci-misc/elmer-post/elmer-post-9999.ebuild
new file mode 100644
index 000000000..5ad6804d2
--- /dev/null
+++ b/sci-misc/elmer-post/elmer-post-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+
+inherit autotools eutils flag-o-matic subversion
+
+ELMER_ROOT="elmerfem"
+MY_PN=${PN/elmer-/}
+
+DESCRIPTION="Elmer is a collection of finite element programs, libraries, and visualization tools, elmerpost"
+HOMEPAGE="http://www.csc.fi/english/pages/elmer"
+#SRC_URI="http://elmerfem.svn.sourceforge.net/viewvc/${ELMER_ROOT}/release/${PV}/${MY_PN}/?view=tar -> ${P}.tar.gz"
+SRC_URI=""
+RESTRICT="mirror"
+ESVN_REPO_URI="https://elmerfem.svn.sourceforge.net/svnroot/elmerfem/trunk/${MY_PN}"
+ESVN_PROJECT="${MY_PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl X debug"
+DEPEND="dev-lang/tcl
+ dev-lang/tk
+ opengl? ( virtual/opengl
+ media-libs/ftgl )
+ sci-libs/matc"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PV}/post"
+
+src_prepare() {
+ #unpack ${A}
+ cd "${S}"
+ # configure must be executable
+ #chmod +x configure
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"
+ local myconf
+ export FC="gfortran"
+ export F77="gfortran"
+ myconf="${myconf} --with-matc"
+ use opengl && append-cppflags -I/usr/include/FTGL
+ use debug &&
+ myconf="${myconf} --with-debug" ||
+ myconf="${myconf} --without-debug"
+ econf $myconf \
+ $(use_with X x) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake ELMER_POST_DATADIR="/usr/share/${MY_PN}" DESTDIR="${D}" install || die "emake install failed"
+}