aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/emu')
-rw-r--r--sci-misc/emu/ChangeLog9
-rw-r--r--sci-misc/emu/Manifest4
-rw-r--r--sci-misc/emu/emu-1.10.ebuild60
-rw-r--r--sci-misc/emu/metadata.xml14
4 files changed, 87 insertions, 0 deletions
diff --git a/sci-misc/emu/ChangeLog b/sci-misc/emu/ChangeLog
new file mode 100644
index 000000000..b46038656
--- /dev/null
+++ b/sci-misc/emu/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-electronics/linsmith
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+* emu-1.10 (16 Nov 2005)
+
+ 16 Nov 2005; Lucas Chiesa <lucas.chiesa@gmail.com> emu-1.10.ebuild:
+ Initial import of sci-misc/emu. Thanks Flammie Pirinen
+ <flammie@gentoo.org> for the ebuild. Closes bug #98051.
diff --git a/sci-misc/emu/Manifest b/sci-misc/emu/Manifest
new file mode 100644
index 000000000..ff658c7cb
--- /dev/null
+++ b/sci-misc/emu/Manifest
@@ -0,0 +1,4 @@
+DIST emu-1.10-src.tar.gz 1725276 RMD160 1c7e6da80572160e3add42f1b4bb84e4faed21ae SHA1 50c670d69b42ed0e63833d9a4a3404429b398be8 SHA256 1d962642a3042bc4caa5cf9bd57efb7d4911a664f6acefb6dd17cc277cfd4042
+EBUILD emu-1.10.ebuild 1470 RMD160 b4261fb0a28a0378081246384e626a1182cbcb62 SHA1 38f39d9775f204887a11df68317ea4efed2b15f0 SHA256 f96ffaa3a56a1cd5265e0544da8a51788ec57befbbc2c8ddf6f5d77aa5f432e6
+MISC ChangeLog 337 RMD160 ec7e95ff1fe110b074b4d0af204a5e6ff90ec73a SHA1 fa4ec140311a16b7fdfe00ec422647c239a1b928 SHA256 1aabc0413177c0f66cabe860ae4c3fda5a9df5664a4173817d51e62e0f350c91
+MISC metadata.xml 379 RMD160 1db8292c88b280e4c0b0e6aa4125e4843f737fda SHA1 3e0e8755351024b6cd30ee78010ba18917477751 SHA256 fae1027a22fc5e6a45ca480e8a8a8f70566c843d95386cd379e1a52428ca25c4
diff --git a/sci-misc/emu/emu-1.10.ebuild b/sci-misc/emu/emu-1.10.ebuild
new file mode 100644
index 000000000..dec703bf1
--- /dev/null
+++ b/sci-misc/emu/emu-1.10.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="EMU Speech Database System"
+HOMEPAGE="http://emu.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="as-is" # or EMU?
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="R esps estools nist-sphere nas X"
+
+DEPEND=">=dev-lang/tcl-8.4
+ X? ( virtual/x11 )"
+RDEPEND=">=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3
+ dev-tcltk/bwidget
+ dev-tcltk/tcllib
+ R? ( dev-lang/R )
+ X? ( virtual/x11 )"
+# !R? ( splus )
+# esps? ( esps )
+# estools? ( estools )
+# nist-sphere? ( nist-sphere )
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A}
+ # This tcl install script is partially braindamaged
+ cd ${S}
+ sed -i "s:\$(WISH) ./doinstall.tcl$:\0 --prefix=${D}/usr/ \
+ --tcl_prefix=${D}/usr/ --bin=${D}/usr/bin/ --auto:g" Makefile.in
+}
+
+src_compile() {
+ myconf="--with-tcl=/usr/lib/ --with-tk=/usr/lib/"
+ # --without selectors do not work here:
+ # $(use_with esps) $(use_with estools) $(use_with nist-sphere nist) \
+ # $(use_with nas)"
+ use esps && myconf="$myconf --with-esps"
+ use estools && myconf="$myconf --with-estools"
+ use nist-sphere && myconf="$myconf --with-nist"
+ use nas && myconf="$myconf --with-nas"
+
+ econf $myconf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die "install failed"
+ for f in ${D}/usr/bin/* ; do
+ sed -i "s|${D}||g" $f
+ done
+ dodoc README TODO
+ rm ${D}/usr/COPYING
+}
+
diff --git a/sci-misc/emu/metadata.xml b/sci-misc/emu/metadata.xml
new file mode 100644
index 000000000..8309cd46b
--- /dev/null
+++ b/sci-misc/emu/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>flammie@gentoo.org</email>
+ <name>Flammie Pirinen</name>
+ </maintainer>
+ <longdescription lang="en">
+ EMU is a speech signal database handling and analysis tool
+ collection.
+ </longdescription>
+</pkgmetadata>
+