aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/hfst/hfst-3.0.2.ebuild')
-rw-r--r--sci-misc/hfst/hfst-3.0.2.ebuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/sci-misc/hfst/hfst-3.0.2.ebuild b/sci-misc/hfst/hfst-3.0.2.ebuild
index 3049c4de5..9ed89b652 100644
--- a/sci-misc/hfst/hfst-3.0.2.ebuild
+++ b/sci-misc/hfst/hfst-3.0.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=4
DESCRIPTION="Helsinki Finite State Transducer API and tools"
HOMEPAGE="http://hfst.sourceforge.net/"
@@ -13,20 +13,16 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="+openfst sfst" # foma"
-DEPEND="openfst? ( >sci-misc/openfst-1.2 )
-sfst? ( >sci-misc/sfst-1.3 )
-"
-# foma? ( >sci-misc/foma-0.9.13 )
+DEPEND="
+ openfst? ( >sci-misc/openfst-1.2 )
+ sfst? ( >sci-misc/sfst-1.3 )"
+# foma? ( >sci-misc/foma-0.9.13 )
RDEPEND="${DEPEND}"
-src_configure()
-{
- econf $(use_with openfst) $(use_with sfst) --without-foma
- # $(use_with foma)
-}
-
-src_install()
-{
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS || die "docs missing"
+src_configure() {
+ econf \
+ $(use_with openfst) \
+ $(use_with sfst) \
+ --without-foma
+# $(use_with foma)
}