aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/hfst/hfst-3.3.12.ebuild')
-rw-r--r--sci-misc/hfst/hfst-3.3.12.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-misc/hfst/hfst-3.3.12.ebuild b/sci-misc/hfst/hfst-3.3.12.ebuild
new file mode 100644
index 000000000..45be9b7f3
--- /dev/null
+++ b/sci-misc/hfst/hfst-3.3.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Helsinki Finite State Transducer API and tools"
+HOMEPAGE="http://hfst.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="+openfst sfst foma xml +glib"
+
+RDEPEND="
+ openfst? ( >sci-misc/openfst-1.2 )
+ sfst? ( >sci-misc/sfst-1.3 )
+ foma? ( >sci-misc/foma-0.9.13 )
+ xml? ( dev-libs/libxml2 dev-cpp/libxmlpp )
+ glib? ( dev-libs/glib )"
+DEPEND="${RDEPEND}
+ >=sys-devel/flex-2.5.35
+ sys-devel/bison"
+
+src_configure() {
+ econf \
+ $(use_with openfst) \
+ $(use_with sfst) \
+ $(use_with foma) \
+ $(use_enable xml apertium2fst) \
+ $(use_with glib unicodehandler glib) \
+ --enable-lexc
+}