aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/openfst/openfst-1.3.4.ebuild')
-rw-r--r--sci-misc/openfst/openfst-1.3.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sci-misc/openfst/openfst-1.3.4.ebuild b/sci-misc/openfst/openfst-1.3.4.ebuild
new file mode 100644
index 000000000..70e39d14d
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.3.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils flag-o-matic multilib
+
+DESCRIPTION="Finite State Transducer tools by Google et al."
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://www.openfst.org/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ epatch "${FILESDIR}/kaldi.patch"
+}
+
+src_test() {
+ einfo "make test can take a few hours on moderately modern systems"
+ make test || die "check failed"
+}