aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/openfst/openfst-1.6.1.ebuild')
-rw-r--r--sci-misc/openfst/openfst-1.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sci-misc/openfst/openfst-1.6.1.ebuild b/sci-misc/openfst/openfst-1.6.1.ebuild
new file mode 100644
index 000000000..4507b7e87
--- /dev/null
+++ b/sci-misc/openfst/openfst-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Finite State Transducer tools by Google et al"
+HOMEPAGE="http://www.openfst.org"
+SRC_URI="http://www.openfst.org/twiki/pub/FST/FstDownload/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-compact-fsts
+ --enable-compress
+ --enable-const-fsts
+ --enable-far
+ --enable-linear-fsts
+ --enable-lookahead-fsts
+ --enable-mpdt
+ --enable-ngram-fsts
+ --enable-pdt
+ --enable-special
+ --enable-bin
+ --enable-grm
+ )
+ econf ${myeconfargs[@]}
+}