aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/opennlp-maxent')
-rw-r--r--sci-misc/opennlp-maxent/ChangeLog6
-rw-r--r--sci-misc/opennlp-maxent/metadata.xml8
-rw-r--r--sci-misc/opennlp-maxent/opennlp-maxent-2.4.0.ebuild12
3 files changed, 16 insertions, 10 deletions
diff --git a/sci-misc/opennlp-maxent/ChangeLog b/sci-misc/opennlp-maxent/ChangeLog
index 18f8bc96c..388545bd0 100644
--- a/sci-misc/opennlp-maxent/ChangeLog
+++ b/sci-misc/opennlp-maxent/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sci-misc/opennlp-maxent
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 12 Nov 2014; Justin Lecher <jlec@gentoo.org> opennlp-maxent-2.4.0.ebuild,
+ metadata.xml:
+ Bump to EAPI=5
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/opennlp-maxent/metadata.xml b/sci-misc/opennlp-maxent/metadata.xml
index f3643410d..a9988e63d 100644
--- a/sci-misc/opennlp-maxent/metadata.xml
+++ b/sci-misc/opennlp-maxent/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>flammie@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <maintainer>
+ <email>flammie@gentoo.org</email>
+ </maintainer>
+ <longdescription>
Implementation of statistical classification using
maximum entropy models in opennlp framework.
</longdescription>
diff --git a/sci-misc/opennlp-maxent/opennlp-maxent-2.4.0.ebuild b/sci-misc/opennlp-maxent/opennlp-maxent-2.4.0.ebuild
index 61810653c..f457b03b9 100644
--- a/sci-misc/opennlp-maxent/opennlp-maxent-2.4.0.ebuild
+++ b/sci-misc/opennlp-maxent/opennlp-maxent-2.4.0.ebuild
@@ -2,7 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=5
+
JAVA_PKG_IUSE="source examples doc"
+
inherit eutils java-pkg-2 java-ant-2
MY_PN="maxent"
@@ -15,10 +18,10 @@ SRC_URI="mirror://sourceforge/maxent/${MY_P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86"
-
IUSE="${IUSE}"
-COMMON_DEP="dev-java/java-getopt
+COMMON_DEP="
+ dev-java/java-getopt
dev-java/trove"
DEPEND=">=virtual/jdk-1.4
${COMMON_DEP}"
@@ -28,9 +31,8 @@ RDEPEND=">=virtual/jre-1.4
EANT_BUILD_TARGET="compile package"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"/lib
+src_prepare() {
+ cd "${S}"/lib || die
rm -v *.jar || die "failed to rm jars"
java-pkg_jarfrom java-getopt-1 gnu.getopt.jar java-getopt.jar
java-pkg_jarfrom trove