aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/salome-component')
-rw-r--r--sci-misc/salome-component/ChangeLog4
-rw-r--r--sci-misc/salome-component/Manifest4
-rw-r--r--sci-misc/salome-component/salome-component-5.1.3.ebuild28
3 files changed, 13 insertions, 23 deletions
diff --git a/sci-misc/salome-component/ChangeLog b/sci-misc/salome-component/ChangeLog
index 8909ce515..e105d6c40 100644
--- a/sci-misc/salome-component/ChangeLog
+++ b/sci-misc/salome-component/ChangeLog
@@ -1,6 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 04 Apr 2010; Etienne Lorriaux <etienne.lorriaux@gmail.com>
+ salome-component-5.1.3.ebuild:
+ changed fetch URL + cleaning
+
*salome-component-5.1.3 (14 Mar 2010)
14 Mar 2010; Etienne Lorriaux <etienne.lorriaux@gmail.com>
diff --git a/sci-misc/salome-component/Manifest b/sci-misc/salome-component/Manifest
index 3ec0181e3..503b5e9fb 100644
--- a/sci-misc/salome-component/Manifest
+++ b/sci-misc/salome-component/Manifest
@@ -1,5 +1,5 @@
AUX salome-component-5.1.3-mpi.patch 718 RMD160 4cfed4cf318686774a49fb037c31dc1ff24be94c SHA1 bd2d3ce92ccb57a81033f8639e8624874b529614 SHA256 9b9b85eaf19409927055fa31899aedd765ea1da05bfe5e8d58a8c8fde792345a
DIST src5.1.3.tar.gz 106470135 RMD160 f46ac847ab57c76df524ddf358b887662fc862cf SHA1 643c775f90277314983747e002918ee5b826db90 SHA256 78ce2acc9cfa474e030723674f4420c420fd2de926b1939455c3716f1fd48a2b
-EBUILD salome-component-5.1.3.ebuild 3095 RMD160 aaa92c9311e01f4ea8038edbc1aa686bc3b7b002 SHA1 80741d116eb4094b7d688c03d7460bc3099c25d3 SHA256 56c29db520a2c715e65da33a78e1a4fdcb6c2a42a5b85a275e498bf28b410df2
-MISC ChangeLog 1452 RMD160 6da8265d00db25d2de4ecfe365258ed55a912af4 SHA1 9352db644331b5dd2b8b47710249470180939150 SHA256 0f2a83dc38202d28cd6135647090dfe2c9a7c27c353fc01bd9c112778488072f
+EBUILD salome-component-5.1.3.ebuild 2991 RMD160 ca1756c309312d4dbca0b1f7a15c731032b151d3 SHA1 a5c6313d4e97bc2749d377ae1028bede7354f483 SHA256 16f22b182a4b7a9ab12162c3f7f1d92bf5ec609c589d07ffeb547454999bae8c
+MISC ChangeLog 1578 RMD160 f8f1d7199da6997c379b2bcaa32b8c9c31b7f932 SHA1 9a7ffbf5f1727510110e12ec7f834173030075ab SHA256 e331022430b2b449271d6662ebb654318c9df4aa91441883113a57abca747a5d
MISC metadata.xml 157 RMD160 ed43b99e7bf8bbf62cf4e46152138ab42d3a88c5 SHA1 2182a6de0b10959aad51af2990f1a6c69e34dd97 SHA256 750cb9e46ac2b77e1adf73de43c186a8c2d2234a9c6a89d9358d0969dc5cf8ac
diff --git a/sci-misc/salome-component/salome-component-5.1.3.ebuild b/sci-misc/salome-component/salome-component-5.1.3.ebuild
index 53f0f83fe..a9f3d4ae2 100644
--- a/sci-misc/salome-component/salome-component-5.1.3.ebuild
+++ b/sci-misc/salome-component/salome-component-5.1.3.ebuild
@@ -5,11 +5,11 @@
EAPI=2
PYTHON_DEPEND="2:2.4"
-inherit distutils eutils flag-o-matic
+inherit eutils flag-o-matic python
DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. COMPONENT Component"
HOMEPAGE="http://www.salome-platform.org"
-SRC_URI="http://www.stasyan.com/devel/distfiles/src${PV}.tar.gz"
+SRC_URI="http://files.opencascade.com/Salome/Salome${PV}/src${PV}.tar.gz"
LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
@@ -38,20 +38,16 @@ DEPEND="${RDEPEND}
dev-libs/libxml2"
MODULE_NAME="COMPONENT"
-MY_S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
+S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
COMPONENT_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
-export OPENPBS="/usr"
pkg_setup() {
- PYVER=$(python_get_version)
- [[ ${PYVER} > 2.4 ]] && \
+ [[ $(python_get_version) > 2.4 ]] && \
ewarn "Python 2.4 is highly recommended for Salome..."
}
src_prepare() {
- cd "${MY_S}"
-
rm -r -f autom4te.cache
./build_configure
}
@@ -59,8 +55,6 @@ src_prepare() {
src_configure() {
local myconf=""
- cd "${MY_S}"
-
# --without-mpi does not disable mpi support, just omit it to disable
if use mpi; then
append-ldflags -lmpi -lmpi_cxx
@@ -77,23 +71,15 @@ src_configure() {
--docdir=${INSTALL_DIR}/doc/salome \
--infodir=${INSTALL_DIR}/share/info \
--libdir=${INSTALL_DIR}/$(get_libdir)/salome \
- --with-python-site=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
- --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome \
+ --with-python-site=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
+ --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
${myconf} \
$(use_enable debug ) \
$(use_enable !debug production ) \
|| die "econf failed"
}
-src_compile() {
- cd "${MY_S}"
-
- emake || die "emake failed"
-}
-
src_install() {
- cd "${MY_S}"
-
emake DESTDIR="${D}" install \
|| die "emake install failed"
@@ -102,7 +88,7 @@ src_install() {
echo "${MODULE_NAME}_ROOT_DIR=${INSTALL_DIR}" > ./90${P}
echo "LDPATH=${INSTALL_DIR}/$(get_libdir)/salome" >> ./90${P}
echo "PATH=${INSTALL_DIR}/bin/salome" >> ./90${P}
- echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome" >> ./90${P}
+ echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome" >> ./90${P}
doenvd 90${P}
rm adm_local/Makefile
insinto "${INSTALL_DIR}"