aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/salome-smesh')
-rw-r--r--sci-misc/salome-smesh/ChangeLog5
-rw-r--r--sci-misc/salome-smesh/Manifest14
-rw-r--r--sci-misc/salome-smesh/salome-smesh-5.1.4.ebuild110
3 files changed, 118 insertions, 11 deletions
diff --git a/sci-misc/salome-smesh/ChangeLog b/sci-misc/salome-smesh/ChangeLog
index b42007da3..ddd0faf2e 100644
--- a/sci-misc/salome-smesh/ChangeLog
+++ b/sci-misc/salome-smesh/ChangeLog
@@ -1,6 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*salome-smesh-5.1.4 (27 Oct 2010)
+
+ 27 Oct 2010; Thomas Kahle <tomka@gentoo.org> +salome-smesh-5.1.4.ebuild:
+ Bump to 5.1.4, ebuild by Michael Riss in bug 330303
+
29 Jun 2010; Justin Lecher <jlec@gentoo.org> salome-smesh-5.1.3.ebuild:
Python ABI fixes
diff --git a/sci-misc/salome-smesh/Manifest b/sci-misc/salome-smesh/Manifest
index 21eb38ede..af847abde 100644
--- a/sci-misc/salome-smesh/Manifest
+++ b/sci-misc/salome-smesh/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
DIST src5.1.3.tar.gz 106470135 RMD160 f46ac847ab57c76df524ddf358b887662fc862cf SHA1 643c775f90277314983747e002918ee5b826db90 SHA256 78ce2acc9cfa474e030723674f4420c420fd2de926b1939455c3716f1fd48a2b
+DIST src5.1.4.tar.gz 120063320 RMD160 c309cebcc4808071d72b5a335185002d69d1420f SHA1 a8b922424af634bda35269e6049a1262e27fc260 SHA256 dd59384ad4fbbbe49c72e946eed9e0f6144a01c799efab62033113a3db46eeae
EBUILD salome-smesh-5.1.3.ebuild 3144 RMD160 39b03ea5cfff4c124768315ffa4309463d666905 SHA1 f5782f5029d59e01973852870871b66b31cfc36b SHA256 9702e6a7f6e36d0f8d388e021e162bd1a0db57688623a91318f140f56a340697
-MISC ChangeLog 2062 RMD160 da6529ad9ded3ecceff7722963199bf3de7affc2 SHA1 e457a15e4a99784ffc645794adcd49275691647b SHA256 ceec1a01eb264273e191c24fe9e5470a3be7e8d308ff06c7957d0d7f6471f9a9
+EBUILD salome-smesh-5.1.4.ebuild 3231 RMD160 64304b915c0a4b80904874c6d33e684274321c1f SHA1 3f49296be73ef3a0a7e6c2e34ac2bea5a6b0eb3b SHA256 3f181f615e875d22f0b9db1b19b0d4ef322d9a485dc7110753ba7f3041cd04dc
+MISC ChangeLog 2227 RMD160 b8fbfb761f6c1a38e2c89868ecf5abcbb0d6a9c5 SHA1 dd6a42c49f2f6ddbc2b04c00e4d59c1538b08c85 SHA256 0d0e3c6dca9bdc8a575289b0a38f007a08365ec2268823d4d1cf77e039c33330
MISC metadata.xml 156 RMD160 dc078172bfebcb25d69bdf8731714f9cce9d3e36 SHA1 da2b240a255820145b7c83a5c48e45b96b7e9ee6 SHA256 5d22100902db7507a5b5493dd4a66cdb08025faf80a2c0b75e6392315c47f900
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v2.0.15 (GNU/Linux)
-
-iEYEARECAAYFAkwqWmQACgkQgAnW8HDreRa4gwCcDQsdOaRwtb5kq35z79obW+ry
-hBEAoKZL+6PPfP8NTxs7NuuOIkPIW9X2
-=XDJs
------END PGP SIGNATURE-----
diff --git a/sci-misc/salome-smesh/salome-smesh-5.1.4.ebuild b/sci-misc/salome-smesh/salome-smesh-5.1.4.ebuild
new file mode 100644
index 000000000..bf814fde9
--- /dev/null
+++ b/sci-misc/salome-smesh/salome-smesh-5.1.4.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="2:2.4"
+
+inherit eutils flag-o-matic python
+
+DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical Simulation. SMESH Component"
+HOMEPAGE="http://www.salome-platform.org"
+SRC_URI="http://files.opencascade.com/Salome/Salome${PV}/src${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc mpi opengl"
+
+RDEPEND="opengl? ( virtual/opengl )
+ mpi? ( || ( sys-cluster/openmpi[cxx]
+ sys-cluster/mpich2[cxx] ) )
+ debug? ( dev-util/cppunit )
+ >=sci-misc/salome-kernel-${PV}
+ >=sci-misc/salome-med-${PV}
+ >=sci-misc/salome-geom-${PV}
+ >=dev-python/omniorbpy-3.4
+ >=net-misc/omniORB-4.1.4
+ >=x11-libs/qt-core-4.5.2
+ >=x11-libs/qt-gui-4.5.2
+ >=x11-libs/qt-opengl-4.5.2
+ >=x11-libs/qwt-5.2
+ >=dev-libs/boost-1.40.0
+ >=sci-libs/opencascade-6.3
+ >=sci-libs/hdf5-1.6.4
+ >=sci-libs/med-2.3.5
+ >=sci-libs/vtk-5.0[python]"
+
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ >=app-doc/doxygen-1.5.6
+ media-gfx/graphviz
+ >=dev-python/docutils-0.4"
+
+MODULE_NAME="SMESH"
+S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
+INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
+SMESH_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
+
+pkg_setup() {
+ [[ $(python_get_version) > 2.4 ]] && \
+ ewarn "Python 2.4 is highly recommended for Salome..."
+ python_set_active_version 2
+ append-ldflags $(no-as-needed)
+}
+
+src_prepare() {
+ rm -r -f autom4te.cache
+ ./build_configure
+}
+
+src_configure() {
+ local vtk_suffix=""
+
+ has_version ">=sci-libs/vtk-5.0" && vtk_suffix="-5.0"
+ has_version ">=sci-libs/vtk-5.2" && vtk_suffix="-5.2"
+ has_version ">=sci-libs/vtk-5.4" && vtk_suffix="-5.4"
+ has_version ">=sci-libs/vtk-5.6" && vtk_suffix="-5.6"
+
+ use amd64 && append-flags -DHAVE_F77INT64
+
+ # Configuration
+ econf --prefix=${INSTALL_DIR} \
+ --datadir=${INSTALL_DIR}/share/salome \
+ --docdir=${INSTALL_DIR}/doc/salome \
+ --infodir=${INSTALL_DIR}/share/info \
+ --libdir=${INSTALL_DIR}/$(get_libdir)/salome \
+ --with-python-site=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
+ --with-python-site-exec=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome \
+ --with-vtk=${VTKHOME} \
+ --with-vtk-version=${vtk_suffix} \
+ --with-qt='/usr' \
+ --with-qwt_inc='/usr/include/qwt5' \
+ $(use_enable debug ) \
+ $(use_enable !debug production ) \
+ $(use_with opengl opengl /usr) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ use amd64 && dosym ${INSTALL_DIR}/lib64 ${INSTALL_DIR}/lib
+
+ echo "${MODULE_NAME}_ROOT_DIR=${INSTALL_DIR}" > ./90${P}
+ echo "LDPATH=${INSTALL_DIR}/$(get_libdir)/salome" >> ./90${P}
+ echo "PATH=${INSTALL_DIR}/bin/salome" >> ./90${P}
+ echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python$(python_get_version)/site-packages/salome" >> ./90${P}
+ doenvd 90${P}
+ rm adm_local/Makefile
+ insinto "${INSTALL_DIR}"
+ doins -r adm_local
+
+ use doc && dodoc INSTALL
+}
+
+pkg_postinst() {
+ elog "Run \`env-update && source /etc/profile\`"
+ elog "now to set up the correct paths."
+ elog ""
+}