aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/salome-yacs/salome-yacs-5.1.3.ebuild')
-rw-r--r--sci-misc/salome-yacs/salome-yacs-5.1.3.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/sci-misc/salome-yacs/salome-yacs-5.1.3.ebuild b/sci-misc/salome-yacs/salome-yacs-5.1.3.ebuild
new file mode 100644
index 000000000..51b20d1e2
--- /dev/null
+++ b/sci-misc/salome-yacs/salome-yacs-5.1.3.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="2:2.4"
+
+inherit distutils eutils
+
+DESCRIPTION="SALOME : The Open Source Integration Platform for Numerical
+Simulation. YACS component"
+HOMEPAGE="http://www.salome-platform.org"
+SRC_URI="http://www.stasyan.com/devel/distfiles/src${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc opengl"
+
+RDEPEND="opengl? ( virtual/opengl )
+ debug? ( dev-util/cppunit )
+ >=sci-misc/salome-kernel-${PV}
+ >=sci-misc/salome-gui-${PV}
+ >=dev-python/omniorbpy-3.4
+ >=sci-libs/hdf5-1.6.4
+ >=dev-libs/boost-1.40.0
+ >=x11-libs/qt-core-4.5.2
+ >=x11-libs/qt-gui-4.5.2
+ >=x11-libs/qt-opengl-4.5.2
+ >=dev-python/PyQt4-4.5.4
+ >=x11-libs/qscintilla-2.4
+ >=net-misc/omniORB-4.1.3
+ dev-libs/expat"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )
+ >=app-doc/doxygen-1.5.6
+ media-gfx/graphviz
+ >=dev-python/docutils-0.4
+ dev-lang/swig
+ dev-libs/libxml2
+ >=dev-python/celementtree-1.0.5
+ >=dev-python/elementtree-1.2.6"
+
+MODULE_NAME="YACS"
+MY_S="${WORKDIR}/src${PV}/${MODULE_NAME}_SRC_${PV}"
+INSTALL_DIR="/opt/salome-${PV}/${MODULE_NAME}"
+export OPENPBS="/usr"
+
+PYVER=$(python_get_version)
+
+pkg_setup() {
+ [[ ${PYVER} > 2.4 ]] && \
+ ewarn "Python 2.4 is highly recommended for Salome..."
+}
+
+src_prepare() {
+ cd "${MY_S}"
+
+ epatch "${FILESDIR}"/"${P}"-ac_python_devel.patch
+ if use amd64; then
+ epatch "${FILESDIR}"/"${P}"-lib_location.patch
+ epatch "${FILESDIR}"/"${P}"-libdir.patch
+ fi
+
+ rm -r -f autom4te.cache
+ ./clean_configure
+ ./build_configure
+}
+
+src_configure() {
+ cd "${MY_S}"
+
+ econf --prefix=${INSTALL_DIR} \
+ --datadir=${INSTALL_DIR}/share/salome \
+ --docdir=${INSTALL_DIR}/doc/salome \
+ --libdir=${INSTALL_DIR}/$(get_libdir)/salome \
+ --infodir=${INSTALL_DIR}/share/info \
+ --with-qt4=/usr \
+ --with-qt4-libraries=/usr/$(get_libdir)/qt4 \
+ --with-qsci4-includes=/usr/include/Qsci \
+ $(use_enable debug ) \
+ $(use_enable !debug production ) \
+ $(use_with debug cppunit /usr ) \
+ || die "econf failed"
+}
+
+src_compile() {
+ cd "${MY_S}"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ cd "${MY_S}"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ use amd64 && dosym ${INSTALL_DIR}/lib64 ${INSTALL_DIR}/lib
+
+ echo "${MODULE_NAME}_ROOT_DIR=${INSTALL_DIR}" > ./90${P}
+ echo "LDPATH=${INSTALL_DIR}/$(get_libdir)/salome" >> ./90${P}
+ echo "PATH=${INSTALL_DIR}/bin/salome" >> ./90${P}
+ echo "PYTHONPATH=${INSTALL_DIR}/$(get_libdir)/python${PYVER}/site-packages/salome" >> ./90${P}
+ doenvd 90${P}
+ rm adm/Makefile
+ insinto "${INSTALL_DIR}"
+ doins -r adm
+
+ use doc && dodoc AUTHORS INSTALL NEWS README
+}
+
+pkg_postinst() {
+ elog "Run \`env-update && source /etc/profile\`"
+ elog "now to set up the correct paths."
+ elog ""
+}