aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc/stanford-parser/stanford-parser-1.6.ebuild')
-rw-r--r--sci-misc/stanford-parser/stanford-parser-1.6.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sci-misc/stanford-parser/stanford-parser-1.6.ebuild b/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
new file mode 100644
index 000000000..82cbcf4c7
--- /dev/null
+++ b/sci-misc/stanford-parser/stanford-parser-1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV=2007-08-19
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Stanford’s statistical natural language parsers"
+HOMEPAGE="http://www-nlp.stanford.edu/software/"
+SRC_URI="http://www-nlp.stanford.edu/software/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="${IUSE}"
+
+COMMON_DEP=""
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${MY_P}"
+EANT_BUILD_TARGET="compile"
+
+src_install() {
+ java-pkg_dojar stanford-parser.jar
+ if use doc ; then
+ java-pkg_dojavadoc javadoc
+ fi
+ if use source ; then
+ java-pkg_dosrc src
+ fi
+ dodoc README.txt README_dependencies.txt cedict_readme.txt
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ for f in *ser.gz ; do
+ doins ${f}
+ done
+ java-pkg_dolauncher stanford-lexparser --java_args -Xmx200m --main edu.stanford.nlp.parser.lexparser.LexicalizedParser
+ java-pkg_dolauncher stanford-lexparser-gui --java_args "-server -Xmx600m" --main edu.stanford.nlp.parser.ui.Parser
+}