aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/foma/ChangeLog7
-rw-r--r--sci-misc/foma/Manifest3
-rw-r--r--sci-misc/foma/foma-0.9.16_alpha.ebuild47
3 files changed, 55 insertions, 2 deletions
diff --git a/sci-misc/foma/ChangeLog b/sci-misc/foma/ChangeLog
index 4918b470c..f5af3ae7c 100644
--- a/sci-misc/foma/ChangeLog
+++ b/sci-misc/foma/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sci-misc/foma
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*foma-0.9.16_alpha (31 Jul 2012)
+
+ 31 Jul 2012; Flammie Pirinen <flammie@gentoo.org> +foma-0.9.16_alpha.ebuild:
+ Bump foma to version 0.9.16alpha, install headers
+
25 Oct 2011; Justin Lecher <jlec@gentoo.org> metadata.xml:
Removed no-herd from herd tag in metadata.xml
diff --git a/sci-misc/foma/Manifest b/sci-misc/foma/Manifest
index f0f7c4ebe..8af0fee78 100644
--- a/sci-misc/foma/Manifest
+++ b/sci-misc/foma/Manifest
@@ -1 +1,2 @@
-DIST foma-0.9.14alpha.tar.gz 306549 RMD160 f5fc03910a76bb0e95b3e0a0008cae5d369dca16 SHA1 85947de3c71ad06448dc7848945ff1deef4e540c SHA256 8ae2f9681e1ecd8c1bc5b1914e755736a839c620b6111c5ab38e2e253ef3255f
+DIST foma-0.9.14alpha.tar.gz 306549 SHA256 8ae2f9681e1ecd8c1bc5b1914e755736a839c620b6111c5ab38e2e253ef3255f SHA512 deb1a2086d21020d84941025f4e131b6a20262b816def2a43261dedfa928823e59704336cdecf28a56b5fb270786b8a7cc2f3ad8b861920e3e0d5a6fd51a7add WHIRLPOOL 1eb73691cf0d710b41a6e9f7a54da0794a2afa526f0f4185e689d3e3fdee9fdc6fd946c80af8ab47ca9cfefb66cea07b46ebee9d31d064697c5632591e20dace
+DIST foma-0.9.16alpha.tar.gz 328482 SHA256 dc019dcdf6dc8f7e881394f3d76821006e7f0cf6e3fe1c12ac2887fa48d81208 SHA512 8c33de29be11dbbf808243222369ee1e8c17f4659fb2d88ce7b1e53f1161538415e50792981110cf46e50890933573f70d034b258a7d7c596e3c61317d56f369 WHIRLPOOL 2cf481210eef4f46eb42f8c98f157074985d2030fbf0aea8cf1f89b1827f7fabf43c0607cefe40d831a5fb15f92f81a04b546a878b299939c1895d8a4c829787
diff --git a/sci-misc/foma/foma-0.9.16_alpha.ebuild b/sci-misc/foma/foma-0.9.16_alpha.ebuild
new file mode 100644
index 000000000..81c050324
--- /dev/null
+++ b/sci-misc/foma/foma-0.9.16_alpha.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+MY_P=${P/_alpha/alpha}
+
+DESCRIPTION="Finite state toolkit compatible with Xerox tools"
+HOMEPAGE="http://code.google.com/p/foma/"
+SRC_URI="http://${PN}.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="
+ sys-libs/libtermcap-compat
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-2.3
+ >=sys-devel/flex-2.5.35"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed \
+ -e "s/^CFLAGS =/CFLAGS = ${CFLAGS} -fPIC/" \
+ -e 's/ltermcap/lcurses/' \
+ -e 's/ldconfig/true/g' \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake
+ emake libfoma
+}
+
+src_install() {
+ # since install target doesn't have DESTDIR
+ dobin foma flookup cgflookup
+ dolib.so libfoma.so.${PV/_alpha/}
+ insinto /usr/include
+ doins foma.h fomalib.h fomalibconf.h
+ dodoc README README.symbols
+}