aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-misc')
-rw-r--r--sci-misc/brlcad/Manifest4
-rw-r--r--sci-misc/brlcad/files/brlcad-7.6.6-gentoo.diff38
2 files changed, 41 insertions, 1 deletions
diff --git a/sci-misc/brlcad/Manifest b/sci-misc/brlcad/Manifest
index 07a56f53b..d30ea93ad 100644
--- a/sci-misc/brlcad/Manifest
+++ b/sci-misc/brlcad/Manifest
@@ -1,2 +1,4 @@
-MD5 a6866dff14458de13f609b14baee6f5d brlcad-7.6.6.ebuild 2222
+MD5 5e60f4e4df628fd5f7bb6038e58c1b29 ChangeLog 283
+MD5 0ae611933c369cdb366665137181e074 brlcad-7.6.6.ebuild 2222
+MD5 b7063256f01b4eaf6d043d843ef572fc files/brlcad-7.6.6-gentoo.diff 1262
MD5 a59a2b5ac2565d0a2b630c1c7bfe59fa files/digest-brlcad-7.6.6 67
diff --git a/sci-misc/brlcad/files/brlcad-7.6.6-gentoo.diff b/sci-misc/brlcad/files/brlcad-7.6.6-gentoo.diff
new file mode 100644
index 000000000..2fac69a63
--- /dev/null
+++ b/sci-misc/brlcad/files/brlcad-7.6.6-gentoo.diff
@@ -0,0 +1,38 @@
+--- configure.ac 2006-01-20 03:25:29.000000000 +0000
++++ configure.ac 2006-01-20 03:33:25.000000000 +0000
+@@ -177,7 +177,7 @@
+ # set up our default shared/non-shared data install directories
+ # e.g. /usr/local/share/brlcad/7.4.0
+ AC_MSG_CHECKING([where BRL-CAD resources are to be installed])
+-if test "x$datadir" = "x\${prefix}/share" ; then
++if test "x$datadir" = "x${prefix}/share" ; then
+ bc_data_dir="${bc_prefix}/share/brlcad/${BRLCAD_VERSION}"
+ elif test "x$datadir" = "x${prefix}/share" ; then
+ bc_data_dir="${bc_prefix}/share/brlcad/${BRLCAD_VERSION}"
+@@ -1905,9 +1905,8 @@
+ #ifdef HAVE_TCL_H
+ # include <tcl.h>
+ #endif
+-#ifdef HAVE_TK_H
++# include <tcl.h>
+ # include <tk.h>
+-#endif
+ #ifndef TK_MAJOR_VERSION
+ # error Unknown major version of Tk
+ #endif
+@@ -2068,14 +2067,12 @@
+ dnl this test is probably not sufficient if iwidgets is not locateable
+ dnl in the tcl auto_path.
+ AC_TRY_RUN([
+-#ifdef HAVE_TCL_H
+ # include <tcl.h>
+-#endif
+ int main() {
+ Tcl_Interp *interp;
+ const char *cmd = "package require Iwidgets";
+ interp = Tcl_CreateInterp();
+- if (Itcl_Init(interp) == TCL_ERROR) {
++ if (Tcl_Init(interp) == TCL_ERROR) {
+ return 1;
+ }
+ if (Tcl_Eval(interp, cmd) != TCL_OK || interp->result[0] == '\0') {