aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/espresso++/espresso++-9999.ebuild')
-rw-r--r--sci-physics/espresso++/espresso++-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/sci-physics/espresso++/espresso++-9999.ebuild b/sci-physics/espresso++/espresso++-9999.ebuild
index d09ae36ff..e7ae60783 100644
--- a/sci-physics/espresso++/espresso++-9999.ebuild
+++ b/sci-physics/espresso++/espresso++-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sci-physics/espresso/espresso-3.1.0.ebuild,v 1.5 2012/05/06 23:08:00 ottxor Exp $
-EAPI=4
+EAPI=5
PYTHON_DEPEND="2:2.6"
@@ -16,11 +16,13 @@ if [[ ${PV} = 9999 ]]; then
EHG_REVISION="default"
inherit mercurial
else
- SRC_URI="https://www.espresso-pp.de/Download/${PN%++}pp_${PV//./_}.tgz"
- S="${WORKDIR}/${PN%++}pp"
+ SRC_URI="https://espressopp.mpip-mainz.mpg.de/Download/${PN//+/p}-${PV}.tgz"
+ S="${WORKDIR}/${PN//+/p}-${PV}"
fi
-LICENSE="GPL-3"
+CMAKE_REMOVE_MODULES_LIST="FindBoost"
+
+LICENSE="GPL-3 !system-boost? ( Boost-1.0 )"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
IUSE="-system-boost"
@@ -40,7 +42,7 @@ pkg_setup() {
src_configure() {
mycmakeargs=(
- $(cmake-utils_use system-boost EXTERNAL_BOOST)
+ $(cmake-utils_use system-boost EXTERNAL_BOOST)
)
cmake-utils_src_configure
}