aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/geant-vmc/geant-vmc-9999.ebuild')
-rw-r--r--sci-physics/geant-vmc/geant-vmc-9999.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/sci-physics/geant-vmc/geant-vmc-9999.ebuild b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
index deaf458a0..2e5507d11 100644
--- a/sci-physics/geant-vmc/geant-vmc-9999.ebuild
+++ b/sci-physics/geant-vmc/geant-vmc-9999.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit cmake-utils versionator git-r3
+inherit cmake-utils versionator
if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
EGIT_REPO_URI=" http://root.cern.ch/git/geant4_vmc.git"
KEYWORDS=""
else
MPV=$(get_version_component_range 2-)
- SRC_URI="ftp://root.cern.ch/root/vmc/geant4_vmc.${MPV}.tar.gz"
+ SRC_URI="http://root.cern.ch/download/vmc/geant4_vmc.${MPV}.tar.gz"
+ S="${WORKDIR}/geant4_vmc.${MPV}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
fi
@@ -31,12 +33,12 @@ DEPEND="${RDEPEND}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use vgm Geant4VMC_USE_VGM)
- $(cmake-utils_use geant3 Geant4VMC_USE_GEANT4_G3TOG4)
- $(cmake-utils_use g4root Geant4VMC_USE_G4Root)
- $(cmake-utils_use mtroot Geant4VMC_USE_MTRoot)
- $(cmake-utils_use test Geant4VMC_BUILD_EXAMPLES)
- $(cmake-utils_use examples Geant4VMC_INSTALL_EXAMPLES)
+ -DGeant4VMC_USE_VGM="$(usex vgm)"
+ -DGeant4VMC_USE_GEANT4_G3TOG4="$(usex geant3)"
+ -DGeant4VMC_USE_G4Root="$(usex g4root)"
+ -DGeant4VMC_USE_MTRoot="$(usex mtroot)"
+ -DGeant4VMC_BUILD_EXAMPLES="$(usex test)"
+ -DGeant4VMC_INSTALL_EXAMPLES="$(usex examples)"
)
cmake-utils_src_configure
}