aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/qcl/files')
-rw-r--r--sci-physics/qcl/files/qcl-0.6.2.patch32
-rw-r--r--sci-physics/qcl/files/qcl-0.6.3-gcc43.patch10
-rw-r--r--sci-physics/qcl/files/qcl-0.6.3-makefile.patch22
3 files changed, 32 insertions, 32 deletions
diff --git a/sci-physics/qcl/files/qcl-0.6.2.patch b/sci-physics/qcl/files/qcl-0.6.2.patch
deleted file mode 100644
index 706a20016..000000000
--- a/sci-physics/qcl/files/qcl-0.6.2.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -r -U4 qcl-0.6.2/Makefile qcl-0.6.2.new/Makefile
---- qcl-0.6.2/Makefile 2006-05-18 15:20:15.000000000 +0200
-+++ qcl-0.6.2.new/Makefile 2006-09-21 02:42:51.000000000 +0200
-@@ -29,11 +29,12 @@
- #ARCHOPT = -m32 -march=i686
-
- # Debugging and optimization options
-
-+OPT = -g -O2
- #DEBUG = -g -pg -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
--DEBUG = -O2 -g -DQCL_DEBUG -DQC_DEBUG
-+DEBUG = $(OPT) -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -O2
-
- # Plotting support
- #
-diff -r -U4 qcl-0.6.2/qc/Makefile qcl-0.6.2.new/qc/Makefile
---- qcl-0.6.2/qc/Makefile 2006-05-18 15:20:15.000000000 +0200
-+++ qcl-0.6.2.new/qc/Makefile 2006-09-21 02:41:51.000000000 +0200
-@@ -15,9 +15,10 @@
- #ARCHOPT = -m32 -march=i686
-
- # Debugging options
-
--DEBUG = -g -O2 -DQC_DEBUG
-+OPT = -g -O2
-+DEBUG = $(OPT) -DQC_DEBUG
- #DEBUG = -g -pg -DQC_DEBUG
- #DEBUG = -O2
-
- # Comment out if you if you want to use SysV Xrand48() linear congruential
diff --git a/sci-physics/qcl/files/qcl-0.6.3-gcc43.patch b/sci-physics/qcl/files/qcl-0.6.3-gcc43.patch
new file mode 100644
index 000000000..1829635b3
--- /dev/null
+++ b/sci-physics/qcl/files/qcl-0.6.3-gcc43.patch
@@ -0,0 +1,10 @@
+--- options.cc.orig 2010-05-26 18:06:46.000000000 +0100
++++ options.cc 2010-05-26 18:14:33.000000000 +0100
+@@ -15,6 +15,7 @@
+
+ #include <stdio.h>
+ #include <time.h>
++#include <string.h>
+
+ #include "options.h"
+ #include "error.h"
diff --git a/sci-physics/qcl/files/qcl-0.6.3-makefile.patch b/sci-physics/qcl/files/qcl-0.6.3-makefile.patch
new file mode 100644
index 000000000..4d13bb16a
--- /dev/null
+++ b/sci-physics/qcl/files/qcl-0.6.3-makefile.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2010-05-26 18:06:39.000000000 +0100
++++ Makefile 2010-05-26 18:17:08.000000000 +0100
+@@ -32,7 +32,7 @@
+
+ #DEBUG = -g -pg -DQCL_DEBUG -DQC_DEBUG
+ #DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
+-DEBUG = -O2 -g -DQCL_DEBUG -DQC_DEBUG
++DEBUG = -DQCL_DEBUG -DQC_DEBUG
+ #DEBUG = -O2
+
+ # Plotting support
+@@ -73,8 +73,8 @@
+
+ #CXX = g++
+ #CPP = $(CC) -E
+-CXXFLAGS = -c $(ARCHOPT) -Wall $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
+-LDFLAGS = $(ARCHOPT) -L$(QCDIR) $(DEBUG) $(PLLIB) -lm -lfl -lqc $(RLLIB)
++CXXFLAGS += -c $(PLOPT) $(DEBUG) $(RLOPT) $(IRQOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
++LDFLAGS += -L$(QCDIR) $(PLLIB) -lm -lfl -lqc $(RLLIB)
+
+ FILESCC = $(wildcard *.cc)
+ FILESH = $(wildcard *.h)