aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/qcl/qcl-0.6.2.ebuild')
-rw-r--r--sci-physics/qcl/qcl-0.6.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-physics/qcl/qcl-0.6.2.ebuild b/sci-physics/qcl/qcl-0.6.2.ebuild
new file mode 100644
index 000000000..b50b5c93e
--- /dev/null
+++ b/sci-physics/qcl/qcl-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
+HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="doc"
+RESTRICT="nomirror"
+SRC_URI="http://tph.tuwien.ac.at/~oemer/tgz/qcl-0.6.2.tgz
+ doc? ( http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
+ http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf )"
+DEPENDS="media-libs/plotutils"
+
+src_compile() {
+ emake QCLDIR="/usr/share/${PN}" || die "emake failed"
+}
+
+src_install() {
+ make QCLDIR="${D}/usr/share/${PN}" QCLBIN="${D}/usr/bin" install \
+ || die "install failed"
+ dodoc README CHANGES
+ if use doc ; then
+ insinto "/usr/share/doc/${PF}"
+ cd "${DISTDIR}"
+ doins structquprog.pdf qcldoc.pdf quprog.pdf
+ fi
+}