aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/qcl')
-rw-r--r--sci-physics/qcl/files/qcl-0.6.4-makefile.patch22
-rw-r--r--sci-physics/qcl/files/qcl-0.6.4-makefile_v2.patch31
-rw-r--r--sci-physics/qcl/qcl-0.6.4-r1.ebuild53
-rw-r--r--sci-physics/qcl/qcl-0.6.4.ebuild44
4 files changed, 0 insertions, 150 deletions
diff --git a/sci-physics/qcl/files/qcl-0.6.4-makefile.patch b/sci-physics/qcl/files/qcl-0.6.4-makefile.patch
deleted file mode 100644
index e73cee420..000000000
--- a/sci-physics/qcl/files/qcl-0.6.4-makefile.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile
-+++ Makefile
-@@ -32,7 +32,7 @@
-
- #DEBUG = -g -pg -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
--DEBUG = -O2 -g -DQCL_DEBUG -DQC_DEBUG
-+DEBUG = -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -O2
-
- # Plotting support
-@@ -81,8 +81,8 @@
-
- #CXX = g++
- #CPP = $(CC) -E
--CXXFLAGS = -c $(ARCHOPT) $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) $(ENCOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
--LDFLAGS = $(ARCHOPT) -L$(QCDIR) $(DEBUG) $(PLLIB) -lm -lfl -lqc $(RLLIB)
-+CXXFLAGS += -c $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) $(ENCOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
-+LDFLAGS += -L$(QCDIR) $(PLLIB) -lm -lfl -lqc $(RLLIB)
-
- FILESCC = $(wildcard *.cc)
- FILESH = $(wildcard *.h)
diff --git a/sci-physics/qcl/files/qcl-0.6.4-makefile_v2.patch b/sci-physics/qcl/files/qcl-0.6.4-makefile_v2.patch
deleted file mode 100644
index 74b05c5f5..000000000
--- a/sci-physics/qcl/files/qcl-0.6.4-makefile_v2.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -32,7 +32,7 @@
-
- #DEBUG = -g -pg -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -g -DQCL_DEBUG -DQC_DEBUG
--DEBUG = -O2 -g -DQCL_DEBUG -DQC_DEBUG
-+DEBUG = -DQCL_DEBUG -DQC_DEBUG
- #DEBUG = -O2
-
- # Plotting support
-@@ -81,8 +81,8 @@
-
- #CXX = g++
- #CPP = $(CC) -E
--CXXFLAGS = -c $(ARCHOPT) $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) $(ENCOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
--LDFLAGS = $(ARCHOPT) -L$(QCDIR) $(DEBUG) $(PLLIB) -lm -lfl -lqc $(RLLIB)
-+CXXFLAGS += -c $(DEBUG) $(PLOPT) $(RLOPT) $(IRQOPT) $(ENCOPT) -I$(QCDIR) -DDEF_INCLUDE_PATH="\"$(QCLDIR)\""
-+LIBS = -L$(QCDIR) $(PLLIB) -lm -lfl -lqc $(RLLIB)
-
- FILESCC = $(wildcard *.cc)
- FILESH = $(wildcard *.h)
-@@ -127,7 +127,7 @@
- build: qcl $(QCLINC)/default.qcl
-
- qcl: $(OBJECTS) qcl.o $(QCLIB)
-- $(CXX) $(OBJECTS) qcl.o $(LDFLAGS) -o qcl
-+ $(CXX) $(LDFLAGS) $(OBJECTS) qcl.o $(LIBS) -o qcl
-
- $(QCLINC)/default.qcl: extern.cc
- grep "^//!" extern.cc | cut -c5- > $(QCLINC)/default.qcl
diff --git a/sci-physics/qcl/qcl-0.6.4-r1.ebuild b/sci-physics/qcl/qcl-0.6.4-r1.ebuild
deleted file mode 100644
index feb49f2a6..000000000
--- a/sci-physics/qcl/qcl-0.6.4-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
-HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
-SRC_URI="
- http://tph.tuwien.ac.at/~oemer/tgz/${P}.tgz
- doc? (
- http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
- http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
- http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf
- )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc plotutils readline"
-
-REPEND="
- plotutils? ( media-libs/plotutils[X,png] )
- readline? (
- sys-libs/ncurses:0=
- sys-libs/readline:0=
- )"
-DEPEND="${DEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-0.6.3-gcc43.patch
- "${FILESDIR}/${P}"-makefile_v2.patch
-)
-
-src_configure() {
- # there is no configure, Makefile must be modified
- if ! use plotutils; then
- sed -i 's/^PL/#PL/' Makefile || die
- fi
- if ! use readline; then
- sed -i 's/^RL/#RL/' Makefile || die
- fi
-}
-
-src_install() {
- emake \
- QCLDIR="${D}/usr/share/${PN}" \
- QCLBIN="${D}/usr/bin" \
- install
- dodoc CHANGES README
- use doc && dodoc "${DISTDIR}/"{structquprog,qcldoc,quprog}.pdf
-}
diff --git a/sci-physics/qcl/qcl-0.6.4.ebuild b/sci-physics/qcl/qcl-0.6.4.ebuild
deleted file mode 100644
index c3788af50..000000000
--- a/sci-physics/qcl/qcl-0.6.4.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-DESCRIPTION="Quantum Computation Language with an emulator of a quantum computer"
-HOMEPAGE="http://tph.tuwien.ac.at/~oemer/qcl.html"
-SRC_URI="
- http://tph.tuwien.ac.at/~oemer/tgz/${P}.tgz
- doc? (
- http://tph.tuwien.ac.at/~oemer/doc/structquprog.pdf
- http://tph.tuwien.ac.at/~oemer/doc/qcldoc.pdf
- http://tph.tuwien.ac.at/~oemer/doc/quprog.pdf
- )"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-DEPEND="
- media-libs/plotutils
- sys-libs/ncurses:0=
- sys-libs/readline:0="
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}"-0.6.3-gcc43.patch
- "${FILESDIR}/${P}"-makefile.patch
-)
-
-src_prepare() {
- epatch ${PATCHES[@]}
-}
-
-src_install() {
- emake \
- QCLDIR="${D}/usr/share/${PN}" \
- QCLBIN="${D}/usr/bin" install
- dodoc README CHANGES
- use doc && dodoc {structquprog,qcldoc,quprog}.pdf
-}