aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/likwid/likwid-3.0.ebuild')
-rw-r--r--sys-apps/likwid/likwid-3.0.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/sys-apps/likwid/likwid-3.0.ebuild b/sys-apps/likwid/likwid-3.0.ebuild
index f7fad8155..ed57d15cd 100644
--- a/sys-apps/likwid/likwid-3.0.ebuild
+++ b/sys-apps/likwid/likwid-3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2013-2013 Andreas Schäfer
+# Copyright 2013-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -6,7 +6,7 @@ EAPI=4
inherit eutils
-DESCRIPTION="Likwid stands for Like I knew what I am doing. This project contributes easy to use command line tools for Linux to support programmers in developing high performance multi threaded programs."
+DESCRIPTION="Command line tools for developing high performance multi threaded programs"
HOMEPAGE="http://code.google.com/p/likwid/"
SRC_URI="http://likwid.googlecode.com/files/${P}.0.tar.gz"
@@ -16,21 +16,21 @@ KEYWORDS="~amd64"
IUSE="access-daemon"
src_prepare() {
- if use access-daemon ; then
- epatch "${FILESDIR}/use_access_daemon.patch"
- fi
- epatch "${FILESDIR}/likwid.patch"
- sed -i -e "s:/usr/local:$D/usr:" config.mk || die "Couldn't set prefix!"
+ if use access-daemon ; then
+ epatch "${FILESDIR}/use_access_daemon.patch"
+ fi
+ epatch "${FILESDIR}/likwid.patch"
+ sed -i -e "s:/usr/local:$D/usr:" config.mk || die "Couldn't set prefix!"
}
src_compile() {
- emake || die "emake failed"
- emake likwid-bench || die "emake likwid-bench failed"
- }
+ emake || die "emake failed"
+ emake likwid-bench || die "emake likwid-bench failed"
+}
pkg_preinst()
{
- if use access-daemon ; then
- chmod +s $D/usr/bin/likwid-accessD || die "Couldn't set SUID for access daemon"
- fi
+ if use access-daemon ; then
+ chmod +s "${D}/usr/bin/likwid-accessD" || die "Couldn't set SUID for access daemon"
+ fi
}