aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/likwid/likwid-3.0.ebuild')
-rw-r--r--sys-apps/likwid/likwid-3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/likwid/likwid-3.0.ebuild b/sys-apps/likwid/likwid-3.0.ebuild
new file mode 100644
index 000000000..db4aa1908
--- /dev/null
+++ b/sys-apps/likwid/likwid-3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2013-2013 Andreas Schäfer
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Likwid stands for Like I knew what I am doing. This project contributes easy to use command line tools for Linux to support programmers in developing high performance multi threaded programs."
+HOMEPAGE="http://code.google.com/p/likwid/"
+SRC_URI="http://likwid.googlecode.com/files/${P}.0.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="access-daemon"
+
+src_prepare() {
+ if use access-daemon ; then
+ epatch "${FILESDIR}/use_access_daemon.patch"
+ fi
+ epatch "${FILESDIR}/likwid.patch"
+ sed -i -e "s:/usr/local:$D/usr:" config.mk || die "Couldn't set prefix!"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ emake likwid-bench || die "emake likwid-bench failed"
+ }