aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/easybuild-framework/easybuild-framework-4.6.2.ebuild')
-rw-r--r--sys-cluster/easybuild-framework/easybuild-framework-4.6.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-cluster/easybuild-framework/easybuild-framework-4.6.2.ebuild b/sys-cluster/easybuild-framework/easybuild-framework-4.6.2.ebuild
new file mode 100644
index 000000000..0f7421835
--- /dev/null
+++ b/sys-cluster/easybuild-framework/easybuild-framework-4.6.2.ebuild
@@ -0,0 +1,33 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="The easybuild-framework package is the core of EasyBuild."
+HOMEPAGE="
+ https://easybuild.io/
+ https://github.com/easybuilders/easybuild-framework
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+dev-python/flake8[${PYTHON_USEDEP}]
+dev-python/keyring[${PYTHON_USEDEP}]
+dev-python/GitPython[${PYTHON_USEDEP}]
+dev-python/pyyaml[${PYTHON_USEDEP}]
+dev-python/autopep8[${PYTHON_USEDEP}]
+dev-python/requests[${PYTHON_USEDEP}]
+dev-python/cryptography[${PYTHON_USEDEP}]
+dev-python/rich[${PYTHON_USEDEP}]
+dev-python/archspec[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test.patch
+)