aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/hpl/hpl-2.1.ebuild')
-rw-r--r--sys-cluster/hpl/hpl-2.1.ebuild3
1 files changed, 1 insertions, 2 deletions
diff --git a/sys-cluster/hpl/hpl-2.1.ebuild b/sys-cluster/hpl/hpl-2.1.ebuild
index ac066244b..65c09f16a 100644
--- a/sys-cluster/hpl/hpl-2.1.ebuild
+++ b/sys-cluster/hpl/hpl-2.1.ebuild
@@ -26,7 +26,6 @@ src_prepare() {
local mpicc_path="$(mpi_pkg_cc)"
local a=""
local locallib="${EPREFIX}/usr/$(get_libdir)/lib"
- local localblas="$(for i in $($(tc-getPKG_CONFIG) --libs-only-l blas lapack);do a="${a} ${i/-l/${locallib}}.so "; done; echo ${a})"
cp setup/Make.Linux_PII_FBLAS Make.gentoo_hpl_fblas_x86 || die
sed -i \
@@ -35,7 +34,7 @@ src_prepare() {
-e '/^ARCH\>/s,= .*,= gentoo_hpl_fblas_x86,' \
-e '/^MPdir\>/s,= .*,=,' \
-e '/^MPlib\>/s,= .*,=,' \
- -e "/^LAlib\>/s,= .*,= ${localblas}," \
+ -e "/^LAlib\>/s%= .*%= $($(tc-getPKG_CONFIG) --libs blas lapack)%" \
-e "/^LINKER\>/s,= .*,= ${mpicc_path}," \
-e "/^CC\>/s,= .*,= ${mpicc_path}," \
-e "/^CCFLAGS\>/s|= .*|= \$(HPL_DEFS) ${CFLAGS}|" \