aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/lustre/Manifest1
-rw-r--r--sys-cluster/lustre/files/lnet.initd45
-rw-r--r--sys-cluster/lustre/files/lustre-client.initd47
-rw-r--r--sys-cluster/lustre/lustre-2.10.1.ebuild120
-rw-r--r--sys-cluster/lustre/lustre-2.8.0.ebuild116
-rw-r--r--sys-cluster/lustre/lustre-9999.ebuild118
-rw-r--r--sys-cluster/lustre/metadata.xml18
7 files changed, 0 insertions, 465 deletions
diff --git a/sys-cluster/lustre/Manifest b/sys-cluster/lustre/Manifest
deleted file mode 100644
index a2b8f9bf1..000000000
--- a/sys-cluster/lustre/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST lustre-2.10.1.tar.gz 15281445 BLAKE2B 53961a97c435d3eb03dae1fd0a8e080659d2997222ec847c612f9aff27d0e0c0a2ab07255dd958f61737480c18bd08db0965e072501b4ffa331367b984ab71a9 SHA512 a76bf9f489dc4aedce6716e26421c85a99628153c7644fa537a91cc6db8e1a8540d444acac6b2da4a77da52b0962e146c10427347a5f3916a4338de19e11b1a7
diff --git a/sys-cluster/lustre/files/lnet.initd b/sys-cluster/lustre/files/lnet.initd
deleted file mode 100644
index 227780c52..000000000
--- a/sys-cluster/lustre/files/lnet.initd
+++ /dev/null
@@ -1,45 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="Loads lnet module and configures network."
-
-depend() {
- need net
- after bootmisc
-}
-
-start() {
- if [ "${RC_CMD}" = "restart" ];
- then
- einfo "Restarting..."
- fi
-
- ebegin "Loading LNet modules:"
- modprobe lnet
- eend $*
-
- ebegin "Bringing up LNet"
- lnetctl lnet configure --all
- eend $*
-}
-
-stop() {
- local LNETMODULES=( "ko2iblnd" "lnet" "libcfs" )
- ebegin "Bringing down LNet"
- lnetctl lnet unconfigure --all
- eend $*
-
- einfo "Unloading LNet modules:"
- for mod in ${LNETMODULES[@]}; do
- ebegin "... ${mod}"
- modprobe -r ${mod}
- eend $*
- done
-}
-
-status()
-{
- einfo "LNet status:"
- lnetctl net show
-}
diff --git a/sys-cluster/lustre/files/lustre-client.initd b/sys-cluster/lustre/files/lustre-client.initd
deleted file mode 100644
index 2978b42b9..000000000
--- a/sys-cluster/lustre/files/lustre-client.initd
+++ /dev/null
@@ -1,47 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-description="Load lustre modules"
-
-extra_commands="checkmodule"
-
-depend() {
- need lnet
- before netmount
-}
-
-checkmodule() {
- local LOADED="$(lctl modules | awk -F"/" /lustre/'{print $2F}')"
- for mod in ${LOADED[@]}; do
- ewarn "Module is still loaded: ${mod}"
- eend $*
- done
-}
-
-start() {
- if [ "${RC_CMD}" = "restart" ];
- then
- einfo "Restarting Lustre..."
- checkmodule
- fi
-
- ebegin "Loading Lustre modules..."
- modprobe lustre
- eend $*
-}
-
-stop() {
- local LMODULES=( "lustre" "osc" "mgc" "lmv" "fld" "mdc" "fid" "lov" "ptlrpc" )
- ebegin "Trying to unmount all Lustre fs"
- umount -a -t lustre
- eend $*
- einfo "Unloading lustre modules:"
- for mod in ${LMODULES[@]}; do
- ebegin "... ${mod}"
- modprobe -r ${mod}
- eend $*
- done
-
- checkmodule
-}
diff --git a/sys-cluster/lustre/lustre-2.10.1.ebuild b/sys-cluster/lustre/lustre-2.10.1.ebuild
deleted file mode 100644
index b2b1d1b35..000000000
--- a/sys-cluster/lustre/lustre-2.10.1.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WANT_AUTOCONF="2.5"
-WANT_AUTOMAKE="1.15"
-WANT_LIBTOOL="latest"
-
-if [[ $PV = *9999* ]]; then
- scm="git-r3"
- SRC_URI=""
- EGIT_REPO_URI="git://git.whamcloud.com/fs/lustre-release.git"
- KEYWORDS=""
- EGIT_BRANCH="master"
-else
- scm=""
- SRC_URI="https://dev.gentoo.org/~alexxy/distfiles/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-SUPPORTED_KV_MAJOR=4
-SUPPORTED_KV_MINOR=9
-
-inherit ${scm} autotools linux-info linux-mod toolchain-funcs udev flag-o-matic
-
-DESCRIPTION="Lustre is a parallel distributed file system"
-HOMEPAGE="http://wiki.whamcloud.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+client +utils +modules +dlc server readline tests"
-
-RDEPEND="
- virtual/awk
- dlc? ( dev-libs/libyaml )
- readline? ( sys-libs/readline:0 )
- server? (
- >=sys-kernel/spl-0.6.1
- >=sys-fs/zfs-kmod-0.6.1
- sys-fs/zfs
- )
- "
-DEPEND="${RDEPEND}
- dev-python/docutils
- virtual/linux-sources"
-
-REQUIRED_USE="
- client? ( modules )
- server? ( modules )"
-
-pkg_pretend() {
- KVSUPP=${SUPPORTED_KV_MAJOR}.${SUPPORTED_KV_MINOR}.x
- if kernel_is gt ${SUPPORTED_KV_MAJOR} ${SUPPORTED_KV_MINOR}; then
- eerror "Unsupported kernel version! Latest supported one is ${KVSUPP}"
- die
- fi
-}
-
-pkg_setup() {
- filter-mfpmath sse
- filter-mfpmath i386
- filter-flags -msse* -mavx* -mmmx -m3dnow
- linux-mod_pkg_setup
- ARCH="$(tc-arch-kernel)"
- ABI="${KERNEL_ABI}"
-}
-
-src_prepare() {
- if [ ${#PATCHES[0]} -ne 0 ]; then
- epatch ${PATCHES[@]}
- fi
- eapply_user
- if [[ ${PV} == "9999" ]]; then
- # replace upstream autogen.sh by our src_prepare()
- local DIRS="libcfs lnet lustre snmp"
- local ACLOCAL_FLAGS
- for dir in $DIRS ; do
- ACLOCAL_FLAGS="$ACLOCAL_FLAGS -I $dir/autoconf"
- done
- _elibtoolize -q
- eaclocal -I config $ACLOCAL_FLAGS
- eautoheader
- eautomake
- eautoconf
- fi
-}
-
-src_configure() {
- local myconf
- if use server; then
- SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
- myconf="${myconf} --with-spl=${EROOT}usr/src/${SPL_PATH} \
- --with-spl-obj=${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
- ZFS_PATH=$(basename $(echo "${EROOT}usr/src/zfs-"*)) \
- myconf="${myconf} --with-zfs=${EROOT}usr/src/${ZFS_PATH} \
- --with-zfs-obj=${EROOT}usr/src/${ZFS_PATH}/${KV_FULL}"
- fi
- econf \
- ${myconf} \
- --without-ldiskfs \
- --with-linux="${KERNEL_DIR}" \
- $(use_enable dlc) \
- $(use_enable client) \
- $(use_enable utils) \
- $(use_enable modules) \
- $(use_enable server) \
- $(use_enable readline) \
- $(use_enable tests)
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}/lnet.initd" lnet
- newinitd "${FILESDIR}/lustre-client.initd" lustre-client
-}
diff --git a/sys-cluster/lustre/lustre-2.8.0.ebuild b/sys-cluster/lustre/lustre-2.8.0.ebuild
deleted file mode 100644
index 3cf01dd73..000000000
--- a/sys-cluster/lustre/lustre-2.8.0.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WANT_AUTOCONF="2.5"
-WANT_AUTOMAKE="1.15"
-WANT_LIBTOOL="latest"
-
-if [[ $PV = *9999* ]]; then
- KEYWORDS=""
- EGIT_BRANCH="master"
-else
- KEYWORDS="~amd64"
- EGIT_COMMIT="${PV}"
-fi
-
-SUPPORTED_KV_MAJOR=4
-SUPPORTED_KV_MINOR=1
-
-inherit git-r3 autotools linux-info linux-mod toolchain-funcs udev flag-o-matic
-
-DESCRIPTION="Lustre is a parallel distributed file system"
-HOMEPAGE="http://wiki.whamcloud.com/"
-SRC_URI=""
-EGIT_REPO_URI="git://git.whamcloud.com/fs/lustre-release.git"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+client +utils +modules +dlc server readline tests"
-
-RDEPEND="
- virtual/awk
- dlc? ( dev-libs/libyaml )
- readline? ( sys-libs/readline:0 )
- server? (
- >=sys-kernel/spl-0.6.1
- >=sys-fs/zfs-kmod-0.6.1
- sys-fs/zfs
- )
- "
-DEPEND="${RDEPEND}
- dev-python/docutils
- virtual/linux-sources"
-
-REQUIRED_USE="
- client? ( modules )
- server? ( modules )"
-
-pkg_pretend() {
- KVSUPP=${SUPPORTED_KV_MAJOR}.${SUPPORTED_KV_MINOR}.x
- if kernel_is gt ${SUPPORTED_KV_MAJOR} ${SUPPORTED_KV_MINOR}; then
- eerror "Unsupported kernel version! Latest supported one is ${KVSUPP}"
- die
- fi
-}
-
-pkg_setup() {
- filter-mfpmath sse
- filter-mfpmath i386
- filter-flags -msse* -mavx* -mmmx -m3dnow
- linux-mod_pkg_setup
- ARCH="$(tc-arch-kernel)"
- ABI="${KERNEL_ABI}"
-}
-
-src_prepare() {
- if [ ${#PATCHES[0]} -ne 0 ]; then
- epatch ${PATCHES[@]}
- fi
- eapply_user
- # replace upstream autogen.sh by our src_prepare()
- local DIRS="libcfs lnet lustre snmp"
- local ACLOCAL_FLAGS
- for dir in $DIRS ; do
- ACLOCAL_FLAGS="$ACLOCAL_FLAGS -I $dir/autoconf"
- done
- _elibtoolize -q
- eaclocal -I config $ACLOCAL_FLAGS
- eautoheader
- eautomake
- eautoconf
-}
-
-src_configure() {
- local myconf
- if use server; then
- SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
- myconf="${myconf} --with-spl=${EROOT}usr/src/${SPL_PATH} \
- --with-spl-obj=${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
- ZFS_PATH=$(basename $(echo "${EROOT}usr/src/zfs-"*)) \
- myconf="${myconf} --with-zfs=${EROOT}usr/src/${ZFS_PATH} \
- --with-zfs-obj=${EROOT}usr/src/${ZFS_PATH}/${KV_FULL}"
- fi
- econf \
- ${myconf} \
- --without-ldiskfs \
- --with-linux="${KERNEL_DIR}" \
- $(use_enable dlc) \
- $(use_enable client) \
- $(use_enable utils) \
- $(use_enable modules) \
- $(use_enable server) \
- $(use_enable readline) \
- $(use_enable tests)
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}/lnet.initd" lnet
- newinitd "${FILESDIR}/lustre-client.initd" lustre-client
-}
diff --git a/sys-cluster/lustre/lustre-9999.ebuild b/sys-cluster/lustre/lustre-9999.ebuild
deleted file mode 100644
index 1f17955bb..000000000
--- a/sys-cluster/lustre/lustre-9999.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WANT_AUTOCONF="2.5"
-WANT_AUTOMAKE="1.15"
-WANT_LIBTOOL="latest"
-
-if [[ $PV = *9999* ]]; then
- scm="git-r3"
- SRC_URI=""
- EGIT_REPO_URI="git://git.whamcloud.com/fs/lustre-release.git"
- KEYWORDS=""
- EGIT_BRANCH="master"
-else
- scm=""
- SRC_URI="https://dev.gentoo.org/~alexxy/distfiles/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-SUPPORTED_KV_MAJOR=4
-SUPPORTED_KV_MINOR=9
-
-inherit ${scm} autotools linux-info linux-mod toolchain-funcs udev flag-o-matic
-
-DESCRIPTION="Lustre is a parallel distributed file system"
-HOMEPAGE="http://wiki.whamcloud.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+client +utils +modules +dlc server readline tests"
-
-RDEPEND="
- virtual/awk
- dlc? ( dev-libs/libyaml )
- readline? ( sys-libs/readline:0 )
- server? (
- >=sys-kernel/spl-0.6.1
- >=sys-fs/zfs-kmod-0.6.1
- sys-fs/zfs
- )
- "
-DEPEND="${RDEPEND}
- dev-python/docutils
- virtual/linux-sources"
-
-REQUIRED_USE="
- client? ( modules )
- server? ( modules )"
-
-pkg_pretend() {
- KVSUPP=${SUPPORTED_KV_MAJOR}.${SUPPORTED_KV_MINOR}.x
- if kernel_is gt ${SUPPORTED_KV_MAJOR} ${SUPPORTED_KV_MINOR}; then
- eerror "Unsupported kernel version! Latest supported one is ${KVSUPP}"
- die
- fi
-}
-
-pkg_setup() {
- filter-mfpmath sse
- filter-mfpmath i386
- filter-flags -msse* -mavx* -mmmx -m3dnow
- linux-mod_pkg_setup
- ARCH="$(tc-arch-kernel)"
- ABI="${KERNEL_ABI}"
-}
-
-src_prepare() {
- if [ ${#PATCHES[0]} -ne 0 ]; then
- epatch ${PATCHES[@]}
- fi
- eapply_user
- # replace upstream autogen.sh by our src_prepare()
- local DIRS="libcfs lnet lustre snmp"
- local ACLOCAL_FLAGS
- for dir in $DIRS ; do
- ACLOCAL_FLAGS="$ACLOCAL_FLAGS -I $dir/autoconf"
- done
- _elibtoolize -q
- eaclocal -I config $ACLOCAL_FLAGS
- eautoheader
- eautomake
- eautoconf
-}
-
-src_configure() {
- local myconf
- if use server; then
- SPL_PATH=$(basename $(echo "${EROOT}usr/src/spl-"*)) \
- myconf="${myconf} --with-spl=${EROOT}usr/src/${SPL_PATH} \
- --with-spl-obj=${EROOT}usr/src/${SPL_PATH}/${KV_FULL}"
- ZFS_PATH=$(basename $(echo "${EROOT}usr/src/zfs-"*)) \
- myconf="${myconf} --with-zfs=${EROOT}usr/src/${ZFS_PATH} \
- --with-zfs-obj=${EROOT}usr/src/${ZFS_PATH}/${KV_FULL}"
- fi
- econf \
- ${myconf} \
- --without-ldiskfs \
- --with-linux="${KERNEL_DIR}" \
- $(use_enable dlc) \
- $(use_enable client) \
- $(use_enable utils) \
- $(use_enable modules) \
- $(use_enable server) \
- $(use_enable readline) \
- $(use_enable tests)
-}
-
-src_compile() {
- default
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}/lnet.initd" lnet
- newinitd "${FILESDIR}/lustre-client.initd" lustre-client
-}
diff --git a/sys-cluster/lustre/metadata.xml b/sys-cluster/lustre/metadata.xml
deleted file mode 100644
index bb4904291..000000000
--- a/sys-cluster/lustre/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>cluster@gentoo.org</email>
- <name>Gentoo Cluster Project</name>
- </maintainer>
- <longdescription>
-Lustre is a parallel distributed file system, generally used for large scale cluster computing
-</longdescription>
- <use>
- <flag name="client">Enable kernel client modules</flag>
- <flag name="dlc">Enable Dynamic LNET Configuration</flag>
- <flag name="server">Enable kernels server modules</flag>
- <flag name="utils">Enable lustre utils</flag>
- <flag name="tests">Enable installation of tests</flag>
- </use>
-</pkgmetadata>