aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/lapack/lapack-3.5.ebuild')
-rw-r--r--virtual/lapack/lapack-3.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/virtual/lapack/lapack-3.5.ebuild b/virtual/lapack/lapack-3.5.ebuild
new file mode 100644
index 000000000..ea254e512
--- /dev/null
+++ b/virtual/lapack/lapack-3.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="|| (
+ >=sci-libs/lapack-reference-${PV}
+ >=sci-libs/atlas-3.10.1[lapack]
+ )
+ doc? ( >=app-doc/lapack-docs-3.3 )"
+DEPEND=""
+
+
+pkg_pretend() {
+ if [[ -e "${EROOT%/}"/usr/$(get_libdir)/lib${PN}.so ]]; then
+ ewarn "You have still the old ${PN} library symlink present"
+ ewarn "Please delete"
+ ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
+ ewarn "to avoid problems with new ${PN} structure"
+ fi
+}