aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gmail.com>2011-04-08 03:05:57 +0200
committerDiego Elio Pettenò <flameeyes@gmail.com>2011-04-08 03:07:28 +0200
commitc0047ca332d4fba8f3197ce453869a87a5606cd5 (patch)
treea1a66502f8e849d4627e56e6d94bb5bb5b0151ab
parentbuild: don't override CFLAGS in environment. (diff)
downloadsparse-c0047ca332d4fba8f3197ce453869a87a5606cd5.tar.gz
sparse-c0047ca332d4fba8f3197ce453869a87a5606cd5.tar.bz2
sparse-c0047ca332d4fba8f3197ce453869a87a5606cd5.zip
build: add an all-installable target that builds the targets to install.
This is useful for distributions that don't want to build content that won't be installed.
-rw-r--r--Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 99b50bd..1f2b2b6 100644
--- a/Makefile
+++ b/Makefile
@@ -114,7 +114,9 @@ SED_PC_CMD = 's|@version@|$(VERSION)|g; \
all: $(PROGRAMS) sparse.pc
-install: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
+all-installable: $(INST_PROGRAMS) $(LIBS) $(LIB_H) sparse.pc
+
+install: all-installable
$(Q)install -d $(DESTDIR)$(BINDIR)
$(Q)install -d $(DESTDIR)$(LIBDIR)
$(Q)install -d $(DESTDIR)$(MAN1DIR)