summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-05 11:02:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-05 11:02:36 +0000
commit34326dde0dfee13f5768c85753a0fbfd86f17d34 (patch)
tree68ea42fb0e62a1f876eceac394bc31249aeba2e3
parentdev-python/hyphenator: Support Python ABIs. (diff)
downloadsunrise-34326dde0dfee13f5768c85753a0fbfd86f17d34.tar.gz
sunrise-34326dde0dfee13f5768c85753a0fbfd86f17d34.tar.bz2
sunrise-34326dde0dfee13f5768c85753a0fbfd86f17d34.zip
Moved to tree wrt bug #299819
svn path=/sunrise/; revision=10654
-rw-r--r--media-video/rtmpdump/ChangeLog8
-rw-r--r--media-video/rtmpdump/Manifest4
-rw-r--r--media-video/rtmpdump/metadata.xml10
-rw-r--r--media-video/rtmpdump/rtmpdump-2.2d.ebuild59
4 files changed, 0 insertions, 81 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
deleted file mode 100644
index c9637e2a2..000000000
--- a/media-video/rtmpdump/ChangeLog
+++ /dev/null
@@ -1,8 +0,0 @@
-# ChangeLog for media-video/rtmpdump
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
- 30 May 2010; Maxime de Roucy (maxime1986) <maxime.deroucy@gmail.com>
- +rtmpdump-2.2d.ebuild, +metadata.xml:
- New Ebuild for bug 299819 (thanks to Alec M.)
-
diff --git a/media-video/rtmpdump/Manifest b/media-video/rtmpdump/Manifest
deleted file mode 100644
index 3dd2eb808..000000000
--- a/media-video/rtmpdump/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-DIST rtmpdump-2.2d.tgz 118309 RMD160 33f211d8edcedb020789b34c736fd0feba4ba6c1 SHA1 1e4de42fdae647f4810dc9e22d9a76cce74c88cc SHA256 a5660fed0b66e36fb7727b9492d5fe210b87acb6f7b493eb52ac91fbeac84c70
-EBUILD rtmpdump-2.2d.ebuild 1457 RMD160 f02bc3148c1e75e701adf96334a256f70dcc74fc SHA1 9bd28ee76949f2588f1994d23d470d8c0284cfa3 SHA256 231ba62129a2b14ca8f9e8cb7fa9c6c0099c3bab6fff8a6f427619b3a694f840
-MISC ChangeLog 281 RMD160 903ef2c94bc73d71b5466c1e16be08301bb4aa5b SHA1 134e0b91fd3b9bcb12962ffd06e1c4ec7191f070 SHA256 7180d34769a89896c71582fe4ffbba00a1db641f7c5b3b4c95e0c7a6e81fe9ca
-MISC metadata.xml 406 RMD160 d082cdc48861197b75853ae0e5d67dd1aa0b3e8e SHA1 9c0b95b0327a226220fbf586c839254ceedc9bf1 SHA256 fb24b61cf62138c0112a1a833c4f7893c5894b1ce39510598e222211f9423017
diff --git a/media-video/rtmpdump/metadata.xml b/media-video/rtmpdump/metadata.xml
deleted file mode 100644
index 56b799115..000000000
--- a/media-video/rtmpdump/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
- <use>
- <flag name='gnutls'>Use GnuTLS library instead of the default OpenSSL</flag>
- <flag name='polarssl'>Use PolarSSL library instead of the default OpenSSL</flag>
- </use>
-</pkgmetadata>
diff --git a/media-video/rtmpdump/rtmpdump-2.2d.ebuild b/media-video/rtmpdump/rtmpdump-2.2d.ebuild
deleted file mode 100644
index cbf10b12a..000000000
--- a/media-video/rtmpdump/rtmpdump-2.2d.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
-HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
-SRC_URI="http://rtmpdump.mplayerhq.hu/download/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="gnutls polarssl ssl"
-
-DEPEND="ssl? (
- gnutls? ( net-libs/gnutls )
- polarssl? ( !gnutls? ( net-libs/polarssl ) )
- !gnutls? ( !polarssl? ( dev-libs/openssl ) )
- )
- sys-libs/zlib"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if ! use ssl && ( use gnutls || use polarssl ) ; then
- ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
- ewarn "Please review the local USE flags for this package."
- fi
-}
-
-src_prepare() {
- # fix Makefile ( bug #298535 and bug #318353 )
- sed -i 's/\$(MAKEFLAGS)//g' Makefile \
- || die "failed to fix Makefile"
-}
-
-src_compile() {
- local crypto=""
- if use ssl ; then
- if use gnutls ; then
- crypto="GNUTLS"
- elif use polarssl ; then
- crypto="POLARSSL"
- else
- crypto="OPENSSL"
- fi
- fi
-
- emake CC=$(tc-getCC) LD=$(tc-getLD) \
- OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" posix || die "emake failed"
-}
-
-src_install() {
- dobin rtmpdump rtmpsuck rtmpsrv rtmpgw || die "dobin failed"
- dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html || die "dodoc failed"
- doman rtmpdump.1 rtmpgw.8 || die "doman failed"
-}