summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Schultz (mschultz) <mattsch@gmail.com>2010-08-04 19:03:36 +0000
committerMatthew Schultz (mschultz) <mattsch@gmail.com>2010-08-04 19:03:36 +0000
commit436540c7f6d1f7ba61aafc508163ced6e1494e07 (patch)
tree4ae88a3dcf3bc9b6615c75b029b98422ad3a9942
parentnet-analyzer/ncrack: New ebuild for bug 330783 (diff)
downloadsunrise-436540c7f6d1f7ba61aafc508163ced6e1494e07.tar.gz
sunrise-436540c7f6d1f7ba61aafc508163ced6e1494e07.tar.bz2
sunrise-436540c7f6d1f7ba61aafc508163ced6e1494e07.zip
dev-php5/pecl-oauth: New Ebuild for bug 331219
svn path=/sunrise/; revision=11082
-rw-r--r--dev-php5/pecl-oauth/ChangeLog8
-rw-r--r--dev-php5/pecl-oauth/Manifest4
-rw-r--r--dev-php5/pecl-oauth/metadata.xml26
-rw-r--r--dev-php5/pecl-oauth/pecl-oauth-1.0.0.ebuild23
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-php5/pecl-oauth/ChangeLog b/dev-php5/pecl-oauth/ChangeLog
new file mode 100644
index 000000000..22fca9020
--- /dev/null
+++ b/dev-php5/pecl-oauth/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-php5/pecl-oauth
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 04 Aug 2010; Matthew Schultz (mschultz) <mattsch@gmail.com>
+ +pecl-oauth-1.0.0.ebuild, +metadata.xml:
+ New Ebuild for bug 331219
+
diff --git a/dev-php5/pecl-oauth/Manifest b/dev-php5/pecl-oauth/Manifest
new file mode 100644
index 000000000..079be6217
--- /dev/null
+++ b/dev-php5/pecl-oauth/Manifest
@@ -0,0 +1,4 @@
+DIST oauth-1.0.0.tgz 42834 RMD160 d11ee1f97745b3647e6d20ef5c9aaf2a5234f17f SHA1 92fffae4eab67f1970f4b720ad3520376e52c0cf SHA256 1f24df7f3bc949ba68151d9fcb289f9d4e0153edf8aae11365fafda30f1d7200
+EBUILD pecl-oauth-1.0.0.ebuild 446 RMD160 63edf5ffe095b1477c9f4318acad491cc27f30b8 SHA1 2677a49d8887e8302cac73872c63a8ac4cf9fdfd SHA256 44bd535eb0fbca1dcbb3a33c4f5a65250352370b3232b9f82d5abaa923c1fc0b
+MISC ChangeLog 254 RMD160 af4d62174c4b1bffbd5e58e2af4c9c56662987ba SHA1 12c61d965beba2defe72330ad1662f54d3182014 SHA256 a468107c1da7d69b793d9c92c3b6d838e50982b20a55f6dc0c3e417655118ecb
+MISC metadata.xml 910 RMD160 a87a511dc7a05625ec87cb22c49bf3328f43ebdb SHA1 ae57a7ffc6b76627321cf1187c1b9d6645875dbb SHA256 4c6360581b34cde1eaddfa122470bde5faaae9f41b5aa577fdf8bcff3e7166bc
diff --git a/dev-php5/pecl-oauth/metadata.xml b/dev-php5/pecl-oauth/metadata.xml
new file mode 100644
index 000000000..ef75faef3
--- /dev/null
+++ b/dev-php5/pecl-oauth/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+ <longdescription>A native PHP-extension to provide OAuth authentication protocol support</longdescription>
+ <upstream>
+ <maintainer status="active">
+ <email>jawed@php.net</email>
+ <name>John Jawed</name>
+ </maintainer>
+ <maintainer status="active">
+ <email>felipe@php.net</email>
+ <name>Felipe Pena</name>
+ </maintainer>
+ <maintainer status="active">
+ <email>rasmus@php.net</email>
+ <name>Rasmus Lerdorf</name>
+ </maintainer>
+ <maintainer status="active">
+ <email>datibbaw@php.net</email>
+ <name>Tjerk Meesters</name>
+ </maintainer>
+ <doc lang="en">http://php.net/oauth/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php5/pecl-oauth/pecl-oauth-1.0.0.ebuild b/dev-php5/pecl-oauth/pecl-oauth-1.0.0.ebuild
new file mode 100644
index 000000000..7c367b957
--- /dev/null
+++ b/dev-php5/pecl-oauth/pecl-oauth-1.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+PHP_EXT_NAME="oauth"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+DESCRIPTION="A native PHP-extension to provide OAuth authentication protocol support"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-lang/php[curl,hash,ssl]"
+RDEPEND="${DEPEND}"
+
+need_php_by_category