summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2007-08-21 17:05:32 +0000
committerFederico Ferri <mescalinum@gentoo.org>2007-08-21 17:05:32 +0000
commit5fd7d03fe6e20cd7605e638a6f2483bd4577bd83 (patch)
treeb262fe3443f19b9f55dc03b74d4d7718c3474a99
parentx11-misc/kdelnk2wmaker: New Ebuild for bug 188402 (diff)
downloadsunrise-5fd7d03fe6e20cd7605e638a6f2483bd4577bd83.tar.gz
sunrise-5fd7d03fe6e20cd7605e638a6f2483bd4577bd83.tar.bz2
sunrise-5fd7d03fe6e20cd7605e638a6f2483bd4577bd83.zip
games-arcade/vodovod: New Ebuild for bug 183731
svn path=/sunrise/; revision=4469
-rw-r--r--games-arcade/vodovod/ChangeLog8
-rw-r--r--games-arcade/vodovod/Manifest4
-rw-r--r--games-arcade/vodovod/metadata.xml5
-rw-r--r--games-arcade/vodovod/vodovod-1.10.ebuild34
4 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/vodovod/ChangeLog b/games-arcade/vodovod/ChangeLog
new file mode 100644
index 000000000..e7fe5d476
--- /dev/null
+++ b/games-arcade/vodovod/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-arcade/vodovod
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 21 Aug 2007; Federico Ferri (federico__) <mescalinum@gmail.com>
+ +metadata.xml, +vodovod-1.10.ebuild:
+ New Ebuild for bug 183731
+
diff --git a/games-arcade/vodovod/Manifest b/games-arcade/vodovod/Manifest
new file mode 100644
index 000000000..ae205c1ae
--- /dev/null
+++ b/games-arcade/vodovod/Manifest
@@ -0,0 +1,4 @@
+DIST vodovod-1.10-src.tar.gz 403216 RMD160 164db0cf2ffc5af460627a61f70947620224f2c7 SHA1 943335a59c1fc1caf5f8b7345a6cc5b97458f7fc SHA256 ba30919eed676e9d1ab7dc57b72813039eb658fa26442b921c29a489d5c082df
+EBUILD vodovod-1.10.ebuild 781 RMD160 ebe53d5ca03bffb3070f6fcc089384b4a329a372 SHA1 b3a4f2a2fc8b8f60a60cacca0204b70e1261d31a SHA256 53123a1793abcab6148bf5b3f56c3df024d938c5a24ae095483a2b96f54c9468
+MISC ChangeLog 255 RMD160 aacd9c2ac81a1c1ee54540d6684fbc7f099ec206 SHA1 19e425dc1cf7095bcad160e210fc9c5c1c5ec7e8 SHA256 a3f072e51de8d1da5d4013aecd0bacf6d1ef5c6f823cb0c47942cb2454a7723e
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-arcade/vodovod/metadata.xml b/games-arcade/vodovod/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/games-arcade/vodovod/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/games-arcade/vodovod/vodovod-1.10.ebuild b/games-arcade/vodovod/vodovod-1.10.ebuild
new file mode 100644
index 000000000..b2a47e1c5
--- /dev/null
+++ b/games-arcade/vodovod/vodovod-1.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games
+
+DESCRIPTION="A free cross-platform pipe connecting game"
+HOMEPAGE="http://home.gna.org/vodovod/"
+SRC_URI="http://download.gna.org/vodovod/${P}-src.tar.gz"
+
+S="${WORKDIR}/${P}-src"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -e 's:"\(data/[^"]*\)":"'${GAMES_DATADIR}'/'${PN}'/\1":g' -i *.cpp
+}
+
+src_install() {
+ dogamesbin "${PN}" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}/data"
+ doins data/* || die "doins failed"
+ #doicon ${DISTDIR}/${PN}.png
+ make_desktop_entry ${PN} "Vodovod"
+ prepgamesdirs
+}