summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-07-19 21:02:40 +0000
committerStefan Garthe (the_mgt) <themgt@uncensored.citadel.org>2011-07-19 21:02:40 +0000
commit6ca7eaae4092f362333ca75ee1f101fbb917bfcd (patch)
tree0b8c27c5b62146538936045d8594bf940ac94a1e
parentapp-admin/elektra: Fixed static-libs removal. (diff)
downloadsunrise-6ca7eaae4092f362333ca75ee1f101fbb917bfcd.tar.gz
sunrise-6ca7eaae4092f362333ca75ee1f101fbb917bfcd.tar.bz2
sunrise-6ca7eaae4092f362333ca75ee1f101fbb917bfcd.zip
games-board/sdlhana: New Ebuild for bug #375691, thanks to Tommy[D] for review
svn path=/sunrise/; revision=12284
-rw-r--r--games-board/sdlhana/ChangeLog8
-rw-r--r--games-board/sdlhana/Manifest4
-rw-r--r--games-board/sdlhana/metadata.xml15
-rw-r--r--games-board/sdlhana/sdlhana-0.34.ebuild24
4 files changed, 51 insertions, 0 deletions
diff --git a/games-board/sdlhana/ChangeLog b/games-board/sdlhana/ChangeLog
new file mode 100644
index 000000000..e89bd1c8b
--- /dev/null
+++ b/games-board/sdlhana/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-board/sdlhana
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 19 Jul 2011; Stefan Garthe (the_mgt) <themgt@uncensored.citadel.org>
+ +sdlhana-0.34.ebuild, +metadata.xml:
+ New Ebuild for bug #375691, thanks to Tommy[D] for review
+
diff --git a/games-board/sdlhana/Manifest b/games-board/sdlhana/Manifest
new file mode 100644
index 000000000..dd35b37d7
--- /dev/null
+++ b/games-board/sdlhana/Manifest
@@ -0,0 +1,4 @@
+DIST sdlhana-0.34.tar.bz2 660022 RMD160 60bd676de3fc05f72d296d8fc20c9e0ae9db9641 SHA1 f6ce75fa8025795321fc1ca757f44a03ba1ca5e6 SHA256 13dfdf4170c971930b2028bff35b4725f55ae5e1aebc93b94c7582e9fb97d511
+EBUILD sdlhana-0.34.ebuild 548 RMD160 36262f04482d79080397190361a38c841be39867 SHA1 cba65b7b0c7cc8b9e70503626947bc9b78a0fae1 SHA256 a3eb11b3a2a430ec45d6371505fecf5d2e859b91e8c9ae5b34e45df1c4f16477
+MISC ChangeLog 291 RMD160 553e2fd0ae7b82224c50cfb99b44989e28939424 SHA1 0a81631cca89819e6d426a3235b8474a68ed981e SHA256 48808bf56b56cce02a0a18774877348796f83c8bb4b2f9ea0c6495cf6146ab36
+MISC metadata.xml 569 RMD160 63173a5f5e3cb862549b206f9917ae46b297426f SHA1 76f9eb2cc5fdbcd0f43b25ba70dd1246001a0ba7 SHA256 66b606a783ef8f4e2c85a3f467547ab179fe3602c6a622c2357a2ccc48ef969a
diff --git a/games-board/sdlhana/metadata.xml b/games-board/sdlhana/metadata.xml
new file mode 100644
index 000000000..b175037e0
--- /dev/null
+++ b/games-board/sdlhana/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+ <longdescription>SDL Hana is an SDL-based Hanafuda game.</longdescription>
+ <upstream>
+ <maintainer>
+ <email>whistler@savannah.nongnu.org</email>
+ <name>Wei Mingzhi</name>
+ </maintainer>
+ <doc>http://savannah.nongnu.org/support/?group=sdlhana</doc>
+ <bugs-to>http://savannah.nongnu.org/bugs/?group=sdlhana</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/sdlhana/sdlhana-0.34.ebuild b/games-board/sdlhana/sdlhana-0.34.ebuild
new file mode 100644
index 000000000..a1453a439
--- /dev/null
+++ b/games-board/sdlhana/sdlhana-0.34.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils games
+
+DESCRIPTION="Hanafuda card game"
+HOMEPAGE="http://sdlhana.nongnu.org/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="media-libs/libsdl"
+RDEPEND="${DEPEND}"
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} "SDL Hana"
+ prepgamesdirs
+}