summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2010-06-05 10:44:38 +0000
committerMichał Górny <mgorny@gentoo.org>2010-06-05 10:44:38 +0000
commitcc4958e466eaa063bdc81a4f9f5182a51164cbb2 (patch)
tree8c4d57a8cd6fa1b51081af8bbcb21ce84d74d164
parentMoved to tree wrt bug #235952 (diff)
downloadsunrise-cc4958e466eaa063bdc81a4f9f5182a51164cbb2.tar.gz
sunrise-cc4958e466eaa063bdc81a4f9f5182a51164cbb2.tar.bz2
sunrise-cc4958e466eaa063bdc81a4f9f5182a51164cbb2.zip
dev-python/hyphenator: Support Python ABIs.
svn path=/sunrise/; revision=10653
-rw-r--r--dev-python/hyphenator/ChangeLog4
-rw-r--r--dev-python/hyphenator/Manifest4
-rw-r--r--dev-python/hyphenator/hyphenator-0.5.1.ebuild6
3 files changed, 11 insertions, 3 deletions
diff --git a/dev-python/hyphenator/ChangeLog b/dev-python/hyphenator/ChangeLog
index 111aad54f..b5f138968 100644
--- a/dev-python/hyphenator/ChangeLog
+++ b/dev-python/hyphenator/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 05 Jun 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
+ hyphenator-0.5.1.ebuild:
+ Support Python ABIs.
+
15 Jan 2010; Michał Górny (sedzimir) <gentoo@mgorny.alt.pl>
hyphenator-0.5.1.ebuild:
Tested on x86.
diff --git a/dev-python/hyphenator/Manifest b/dev-python/hyphenator/Manifest
index 93ada70f3..8db6c1e03 100644
--- a/dev-python/hyphenator/Manifest
+++ b/dev-python/hyphenator/Manifest
@@ -1,4 +1,4 @@
DIST hyphenator-0.5.1.tar.gz 4213 RMD160 fbdcdc0166e98eb62b764933ad24cb0ba38df6e6 SHA1 ff21d6b5d60114101c71c56a4b11a80a08b0bfb8 SHA256 58464213a4580b3325a48835fc468ec7488fe6297a39cf4aacdaa31933108c0f
-EBUILD hyphenator-0.5.1.ebuild 388 RMD160 72a00b7dbcf3adea8233f431b3b1d6b15f482f1e SHA1 f440010719c3a6854d55e139e5b93a99795ae1b9 SHA256 91c5eea62a5810e915801c7ca08269b8fe2d278de9cdb000c9c44dfefb700695
-MISC ChangeLog 393 RMD160 616c18330683d4af0e3bce867077fd0f47efc690 SHA1 02596a9c041609c790dd928ce85c8e25f2072a21 SHA256 b126e1f261328318222f1a4d0435293ec3797f66cc631f9929def683936cb2f0
+EBUILD hyphenator-0.5.1.ebuild 461 RMD160 07daf4b78888a68551dc71d339f40aee30b4d537 SHA1 d50dc79341c272e1c4eef222fbb64600ebbe8624 SHA256 659b012a06c95a77e2843580431be371a203dfcffaa94ea43b7f82890e628c2b
+MISC ChangeLog 508 RMD160 a5fc0998ba5f31433bc239ae452b310b1cb6dc51 SHA1 99b426ac11f576730052576c2dca30e307795c3f SHA256 a8987ca994fb548e9e7135512038582d7c7b57446de4534b1d27dd6711cf7e62
MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/dev-python/hyphenator/hyphenator-0.5.1.ebuild b/dev-python/hyphenator/hyphenator-0.5.1.ebuild
index 197f80521..ad7d345f2 100644
--- a/dev-python/hyphenator/hyphenator-0.5.1.ebuild
+++ b/dev-python/hyphenator/hyphenator-0.5.1.ebuild
@@ -2,7 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit distutils
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND=2
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils python
DESCRIPTION="Hyphenate text using myspell dictionaries"
HOMEPAGE="http://code.google.com/p/python-hyphenator/"