summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiago Pierezan Camargo (camargo) <tcamargo@gmail.com>2007-10-13 21:26:10 +0000
committerTiago Pierezan Camargo (camargo) <tcamargo@gmail.com>2007-10-13 21:26:10 +0000
commitda5173bb0a716893887346743038c94024907ea4 (patch)
tree4fb89d465b81b940d19e8dfde8483b62e5e79b5c
parentapp-misc/mc-mp: Remove PROVIDE for new-style virtual/editor (diff)
downloadsunrise-da5173bb0a716893887346743038c94024907ea4.tar.gz
sunrise-da5173bb0a716893887346743038c94024907ea4.tar.bz2
sunrise-da5173bb0a716893887346743038c94024907ea4.zip
games-emulation/sdlmame: New Ebuild for bug 145023
svn path=/sunrise/; revision=4768
-rw-r--r--games-emulation/sdlmame/ChangeLog8
-rw-r--r--games-emulation/sdlmame/Manifest4
-rw-r--r--games-emulation/sdlmame/metadata.xml5
-rw-r--r--games-emulation/sdlmame/sdlmame-0.119_p4.ebuild125
4 files changed, 142 insertions, 0 deletions
diff --git a/games-emulation/sdlmame/ChangeLog b/games-emulation/sdlmame/ChangeLog
new file mode 100644
index 000000000..b52ab4427
--- /dev/null
+++ b/games-emulation/sdlmame/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-emulation/sdlmame
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 13 Oct 2007; Tiago Pierezan Camargo (camargo) <tcamargo@gmail.com>
+ +metadata.xml, +sdlmame-0.119_p4.ebuild:
+ New Ebuild for bug 145023
+
diff --git a/games-emulation/sdlmame/Manifest b/games-emulation/sdlmame/Manifest
new file mode 100644
index 000000000..e03a4e413
--- /dev/null
+++ b/games-emulation/sdlmame/Manifest
@@ -0,0 +1,4 @@
+DIST sdlmame0119u4.zip 15894278 RMD160 b425374573d0f72d4fa4fe4b25f420cad39dbc54 SHA1 c9a17e9b61fea93e7156868975980da177567928 SHA256 55f8279f4c56aa8771267ccd89e4bd7c21e802b3085dff421b089c2771474b4a
+EBUILD sdlmame-0.119_p4.ebuild 2683 RMD160 e91d2b4c4cbed09c74b803f577fbde700449d0f4 SHA1 e863c39c32b8549ef70d4a459e407a4464e04960 SHA256 5c9e171473c49d462ab2ee3c5ff7056d24c692432120aef8e2c6752d59d3314a
+MISC ChangeLog 265 RMD160 c0438395e43dacecd0ddd3ffe6bc3ea427b33fbb SHA1 f055cfada144829e2e40f37bba32d8c51013eb4f SHA256 0d6d1478713f15d3112f8803a950eb28545615e3a01fb0eeb7c718fd409ebafe
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/games-emulation/sdlmame/metadata.xml b/games-emulation/sdlmame/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/games-emulation/sdlmame/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/games-emulation/sdlmame/sdlmame-0.119_p4.ebuild b/games-emulation/sdlmame/sdlmame-0.119_p4.ebuild
new file mode 100644
index 000000000..77a89861c
--- /dev/null
+++ b/games-emulation/sdlmame/sdlmame-0.119_p4.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils games flag-o-matic
+
+MY_PV=${PV/./}
+# Minor releases
+MY_PV=${MY_PV/_p/u}
+MY_P=${PN}${MY_PV}
+MY_V=${PV%%_p*}
+
+DESCRIPTION="Multiple Arcade Machine Emulator (SDL)"
+HOMEPAGE="http://rbelmont.mameworld.info/?page_id=163"
+# Hope it goes to gentoo mirrors...
+#SRC_URI="mirror://gentoo/${MY_P}.zip"
+SRC_URI="http://rbelmont.mameworld.info/${MY_P}.zip"
+
+# Same as xmame. Should it be renamed to MAME?
+LICENSE="XMAME"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="minimal debug"
+
+DEPEND=">=media-libs/libsdl-1.2.10
+ sys-libs/zlib
+ dev-libs/expat
+ debug? (
+ >gnome-base/gconf-2
+ >=x11-libs/gtk+-2 )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+RESTRICT="fetch strip"
+
+pkg_nofetch() {
+ einfo "Please download sdlmame from"
+ einfo "${SRC_URI}"
+ einfo "and put the file in ${DISTDIR}"
+ einfo
+}
+
+# Function to disable a makefile option
+disable_feature() {
+ sed -i \
+ -e "/$1.*=/s:^:# :" \
+ "${S}"/makefile || die "disable $1 pacth failed"
+}
+
+# Function to enable a makefile option
+enable_feature() {
+ sed -i \
+ -e "/^#.*$1.*=/s:^# ::" \
+ "${S}"/makefile || die "enable $1 patch failed"
+}
+
+src_unpack() {
+ unpack "${A}"
+ # Don't compile zlib and expat
+ einfo "Disabling embedded libraries: zlib and expat"
+ $(disable_feature BUILD_ZLIB)
+ $(disable_feature BUILD_EXPAT)
+
+ case ${ARCH} in
+ amd64) einfo "Enabling 64-bit support"
+ $(enable_feature PTR64)
+ $(enable_feature AMD64)
+ ;;
+
+ x86) einfo "Optimizing build for $(get-flag march)"
+ case $(get-flag march) in
+ pentium3) $(enable_feature PM);;
+ pentium-m) $(enable_feature PM);;
+ pentium4) $(enable_feature P4);;
+ athlon) $(enable_feature ATHLON);;
+ k7) $(enable_feature ATHLON);;
+ i686) $(enable_feature I686);;
+ pentiumpro) $(enable_feature I686);;
+ esac
+ ;;
+
+ ppc) einfo "Enabling PPC support"
+ $(enable_feature G4)
+ ;;
+ esac
+
+ if use debug ; then
+ $(enable_feature DEBUG)
+ $(enable_feature SYMBOLS)
+ $(enable_feature PROFILE)
+ fi
+
+ #einfo "Applying WolfMAME patches"
+ #cd "${S}"
+ #epatch "${FILESDIR}"/"${MY_V}"
+}
+
+src_compile() {
+ # Minimal driver support. Good for ebuild testing...
+ if use minimal ; then
+ make_opts="SUBTARGET=tiny"
+ fi
+
+ emake \
+ NAME="${PN}" \
+ SUFFIX="" \
+ ${make_opts} \
+ || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${PN}" || die "dogamesbin ${PN} failed"
+
+ # Follows xmame ebuild, avoiding collision on /usr/games/bin/jedutil
+ exeinto $(games_get_libdir)/${PN}
+ local f
+ for f in chdman jedutil romcmp ; do
+ doexe "${f}" || die "doexe ${f} failed"
+ done
+
+ dodoc docs/* *.txt
+
+ prepgamesdirs
+}