summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Fortino (nfortino) <nfortino@gmail.com>2009-03-16 21:00:19 +0000
committerNick Fortino (nfortino) <nfortino@gmail.com>2009-03-16 21:00:19 +0000
commitdcfda50b3233a86928b17a08bf2c6d4eacecef51 (patch)
tree26f459d9bac565da326afc174f24b35c01400a06
parentwww-apps/phpMyProxy: Update ebuild to use EAPI 2. Thanks to Cristian Ruppert ... (diff)
downloadsunrise-dcfda50b3233a86928b17a08bf2c6d4eacecef51.tar.gz
sunrise-dcfda50b3233a86928b17a08bf2c6d4eacecef51.tar.bz2
sunrise-dcfda50b3233a86928b17a08bf2c6d4eacecef51.zip
net-im/pyxmpp: Update ebuild to use EAPI 2. Thanks to Cristian Ruppert and Thomas Sachau for review
svn path=/sunrise/; revision=8101
-rw-r--r--net-im/pyxmpp/ChangeLog7
-rw-r--r--net-im/pyxmpp/Manifest4
-rw-r--r--net-im/pyxmpp/pyxmpp-1.0.0-r2.ebuild17
3 files changed, 13 insertions, 15 deletions
diff --git a/net-im/pyxmpp/ChangeLog b/net-im/pyxmpp/ChangeLog
index ad3fb94f0..764b1b10c 100644
--- a/net-im/pyxmpp/ChangeLog
+++ b/net-im/pyxmpp/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for net-im/pyxmpp
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 16 Mar 2009; Nick Fortino (nfortino) <nfortino@gmail.com>
+ pyxmpp-1.0.0-r2.ebuild:
+ Update ebuild to use EAPI 2. Thanks to Cristian Ruppert and Thomas Sachau
+ for review
+
27 Jul 2008; Thomas Anderson <gentoofan23@gentoo.org>
pyxmpp-1.0.0-r2.ebuild:
Make dohtml die on failure.
diff --git a/net-im/pyxmpp/Manifest b/net-im/pyxmpp/Manifest
index 73ec8328c..f7725cecf 100644
--- a/net-im/pyxmpp/Manifest
+++ b/net-im/pyxmpp/Manifest
@@ -1,4 +1,4 @@
DIST pyxmpp-1.0.0.tar.gz 669021 RMD160 148d07c97ca715985a57984fdc6c228dbe1fb019 SHA1 6a8d88ed79153175698cd0ffc914ea37c3f526ce SHA256 924ba0cde1e630b53784623cdaab35f0da6e81e7b8a11e6927cd38420a781267
-EBUILD pyxmpp-1.0.0-r2.ebuild 941 RMD160 22a2a18767ba86a4e23e6a138c6051f70f9514ad SHA1 959cfd2b492fefcae415f2bbcaa23330e35c5a9c SHA256 9979ebec427dce175de3f5ef3f2b0ba1a68cbca102d8df39ba3aabdb4e5a761e
-MISC ChangeLog 968 RMD160 4fc3f91d157255619cf1fd291155902227e5fb73 SHA1 2cfade323879e139d46a0b17e50b73514047f6f4 SHA256 47fcb66771c3a9869b8d0eeb54a76ad322663b2680a4447bd2dcab8f4190aeb3
+EBUILD pyxmpp-1.0.0-r2.ebuild 656 RMD160 34b636c1dc952590e1883dcb1136f71843665b64 SHA1 69d8be15d0c2965ba316a4a9744fc00eb2f8a3af SHA256 e31a884da5249892d22311ed7e0a308543a3c6bf5ee96447db02a7039b598016
+MISC ChangeLog 1144 RMD160 32e59cd2a8699adcea2b58e7e32e4b0c03d95573 SHA1 f1bb211381acf8b0ea424f082db4cd7c2d5f5d8e SHA256 af2356a13c553bc09536293b3a106ba563cf61b3e429be23d4f05408cb719aa8
MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/net-im/pyxmpp/pyxmpp-1.0.0-r2.ebuild b/net-im/pyxmpp/pyxmpp-1.0.0-r2.ebuild
index 3d766387e..e6e78b535 100644
--- a/net-im/pyxmpp/pyxmpp-1.0.0-r2.ebuild
+++ b/net-im/pyxmpp/pyxmpp-1.0.0-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="2"
+
inherit eutils distutils
DESCRIPTION="A Python XMPP (RFC 3920,3921) and Jabber implementation"
@@ -10,24 +12,15 @@ SRC_URI="http://pyxmpp.jajcus.net/downloads/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
DEPEND=">=dev-lang/python-2.3
- >=dev-libs/libxml2-2.6.23"
+ >=dev-libs/libxml2-2.6.23[python]"
RDEPEND="${DEPEND}
>=dev-python/dnspython-1.3.2
>=dev-python/m2crypto-0.13.1"
-pkg_setup() {
- if ! built_with_use dev-libs/libxml2 python ; then
- eerror "To build pyxmpp, libxml2 must be built with python"
- eerror "bindings. To continue merging pyxmpp, you must first "
- eerror "recompile libxml2 with the python use flag enabled"
- die "pyxmpp requires libxml2 with USE=python"
- fi
-}
-
src_install() {
DOCS="CHANGES"
distutils_src_install