summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Helbling <helch@gmx.ch>2008-01-17 20:47:05 +0000
committerChristian Helbling <helch@gmx.ch>2008-01-17 20:47:05 +0000
commitfeaf06102a7a5666983c2da4234c76ae0e928756 (patch)
tree8c5444f356354e9eca71b949df9c75cedf66bfca
parentnet-p2p/freenet/Manifest: New upstream release (diff)
downloadsunrise-feaf06102a7a5666983c2da4234c76ae0e928756.tar.gz
sunrise-feaf06102a7a5666983c2da4234c76ae0e928756.tar.bz2
sunrise-feaf06102a7a5666983c2da4234c76ae0e928756.zip
sci-calculators/tiemu: Version bump and transfer upstream's renaming (was sci-calculators/tiemu3). Bug is still #112985.
svn path=/sunrise/; revision=5450
-rw-r--r--sci-calculators/tiemu/ChangeLog9
-rw-r--r--sci-calculators/tiemu/Manifest4
-rw-r--r--sci-calculators/tiemu/metadata.xml5
-rw-r--r--sci-calculators/tiemu/tiemu-3.02.ebuild42
4 files changed, 60 insertions, 0 deletions
diff --git a/sci-calculators/tiemu/ChangeLog b/sci-calculators/tiemu/ChangeLog
new file mode 100644
index 000000000..7ef6a4623
--- /dev/null
+++ b/sci-calculators/tiemu/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-calculators/tiemu
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 17 Jan 2008; Christian Helbling <helch@gmx.ch> +metadata.xml,
+ +tiemu-3.02.ebuild:
+ Version bump and transfer upstream's renaming (was sci-calculators/tiemu3).
+ Bug is still #112985.
+
diff --git a/sci-calculators/tiemu/Manifest b/sci-calculators/tiemu/Manifest
new file mode 100644
index 000000000..6a24c45d8
--- /dev/null
+++ b/sci-calculators/tiemu/Manifest
@@ -0,0 +1,4 @@
+DIST tiemu-3.02.tar.bz2 21491214 RMD160 584a8982c2bb052201026931fe9981096c0113a4 SHA1 a533a427236413aeaa4f6feac253c45a9b293b36 SHA256 2b09783a6d30f78165651db99d3da1fbf2890579ef8b359ee74352f7da0f7966
+EBUILD tiemu-3.02.ebuild 948 RMD160 95d879de7d118064b3ba49ec8fe5e35c094fa7ee SHA1 1a3434ac7331a57c0a3817b141cf91f44c3cf438 SHA256 888edf8ca17e7397d87354b070c3217240deb7cafc303f94781a6443c818e8e9
+MISC ChangeLog 311 RMD160 5be4d547c6b6c9171bfe3efc2291018543a9aebc SHA1 455c5b1c7d30dc1132810ada91866a458d160198 SHA256 4b7dd4f97e4c492b455b2f8cba6af5b5e0e110f2a597f23260beb3e6b9711560
+MISC metadata.xml 170 RMD160 645927a396fdc21cdeb089fe42c5397332420ea6 SHA1 ac7f48a14fec325926f9ce1be8fbf1f311b4f2e4 SHA256 d797a2ec6f9dc516c9f9c1a758ee87ad3e8c43101b5dc76c2f872d5bd4639b42
diff --git a/sci-calculators/tiemu/metadata.xml b/sci-calculators/tiemu/metadata.xml
new file mode 100644
index 000000000..7e3286984
--- /dev/null
+++ b/sci-calculators/tiemu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/sci-calculators/tiemu/tiemu-3.02.ebuild b/sci-calculators/tiemu/tiemu-3.02.ebuild
new file mode 100644
index 000000000..4ba09278b
--- /dev/null
+++ b/sci-calculators/tiemu/tiemu-3.02.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils kde-functions
+
+DESCRIPTION="TI89(ti)/92(+)/V200 emulator"
+HOMEPAGE="http://lpg.ticalc.org/prj_tiemu/"
+SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus kde nls"
+
+DEPEND=">=sci-libs/libticables2-1.0.0
+ >=sci-libs/libticalcs2-1.0.7
+ >=sci-libs/libtifiles2-1.0.7
+ >=sci-libs/libticonv-1.0.4
+ >=dev-libs/glib-2.6.0
+ >=gnome-base/libglade-2.4.0
+ >=x11-libs/gtk+-2.6.0
+ nls? ( sys-devel/gettext )
+ dbus? ( >=dev-libs/dbus-glib-0.60 )"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ use kde && set-kdedir 3
+
+ econf \
+ $(use_enable nls) \
+ $(use_with kde) \
+ $(use_enable dbus)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README README.linux RELEASE THANKS TODO
+}