summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Moc <jakub@gentoo.org>2006-06-10 14:48:23 +0000
committerJakub Moc <jakub@gentoo.org>2006-06-10 14:48:23 +0000
commitf6ff549cb0f3023bde0223d63f78057f0277c015 (patch)
tree4d340129ca988ab3b363fd799ff3c95def504eb1 /app-antivirus/panda/panda-9.00.00.ebuild
parentapp-antivirus/kav4fileserver - New ebuild for Kaspersky Anti-Virus for Filese... (diff)
downloadsunrise-f6ff549cb0f3023bde0223d63f78057f0277c015.tar.gz
sunrise-f6ff549cb0f3023bde0223d63f78057f0277c015.tar.bz2
sunrise-f6ff549cb0f3023bde0223d63f78057f0277c015.zip
app-antivirus/panda - New ebuild, initially submitted by Francisco Javier in Bug 78969.
svn path=/; revision=41
Diffstat (limited to 'app-antivirus/panda/panda-9.00.00.ebuild')
-rw-r--r--app-antivirus/panda/panda-9.00.00.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-antivirus/panda/panda-9.00.00.ebuild b/app-antivirus/panda/panda-9.00.00.ebuild
new file mode 100644
index 000000000..88e78789c
--- /dev/null
+++ b/app-antivirus/panda/panda-9.00.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+S=${WORKDIR}
+
+DESCRIPTION="Panda Antivirus for Linux"
+HOMEPAGE="http://www.pandasoftware.com/download/linux/linux.asp"
+SRC_URI="http://shareware.pandasoftware.com/shareware/pavcl_linux.tgz"
+
+SLOT="0"
+LICENSE="Panda-Freeware"
+KEYWORDS="-* ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+PROVIDE="virtual/antivirus"
+
+RESTRICT="mirror strip"
+QA_TEXTRELS_x86="opt/pavcl/usr/lib/libPsk*.so.*"
+
+src_install() {
+ cd ${S}
+ cp -r . ${D}
+
+ dodir /etc/env.d
+ echo "PATH=\"/opt/pavcl/usr/bin\"" >> ${D}/etc/env.d/90panda
+ echo "MANPATH=\"/opt/pavcl/usr/man\"" >> ${D}/etc/env.d/90panda
+}
+
+pkg_postinst() {
+ einfo "See \"man pavcl\" for usage instructions."
+ einfo
+ einfo "Updated virus definitions are not available for free."
+ einfo "You need a username and password to download them"
+ einfo "from http://acs.pandasoftware.com/software/basevirus/"
+}
+
+pkg_prerm() {
+ einfo "Removing stale logdir..."
+ [[ -d "${ROOT}/opt/pavcl/var/log/panda" ]] && rm -rf "${ROOT}/opt/pavcl/var/log/panda"
+}