summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2009-04-26 16:55:34 +0000
committerTom Hendrikx (whyscream) <tom@whyscream.net>2009-04-26 16:55:34 +0000
commitf14ea30127806533b6849adb6a48056ed6731aa1 (patch)
tree726ca6b1298bc2a49248dd69224887f70235da90 /app-backup/rdup/rdup-0.9.1.ebuild
parentdev-util/uncrustify: New ebuild for bug 208199. Thanks to Patrick Lauer and T... (diff)
downloadsunrise-f14ea30127806533b6849adb6a48056ed6731aa1.tar.gz
sunrise-f14ea30127806533b6849adb6a48056ed6731aa1.tar.bz2
sunrise-f14ea30127806533b6849adb6a48056ed6731aa1.zip
app-backup/rdup: version bump
svn path=/sunrise/; revision=8426
Diffstat (limited to 'app-backup/rdup/rdup-0.9.1.ebuild')
-rw-r--r--app-backup/rdup/rdup-0.9.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-backup/rdup/rdup-0.9.1.ebuild b/app-backup/rdup/rdup-0.9.1.ebuild
new file mode 100644
index 000000000..57e32181f
--- /dev/null
+++ b/app-backup/rdup/rdup-0.9.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="The only backup program that doesn't make backups."
+HOMEPAGE="http://www.miek.nl/projects/rdup"
+SRC_URI="http://www.miek.nl/projects/${PN}/${P}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="path-encryption"
+
+DEPEND="app-arch/libarchive
+ dev-libs/glib
+ dev-libs/libpcre
+ path-encryption? ( dev-libs/nettle )"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf $(use_with path-encryption nettle )
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dosym ../lib/rdup/rdup-simple.sh /usr/bin/rdup-simple || die "dosym failed"
+
+ dodoc AUTHORS ChangeLog DESIGN README || die "dodoc failed"
+}