summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-08-18 20:36:36 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-08-18 20:36:36 +0000
commit204f29480f16ec53e01743fb4b8a4e6cfe98f76e (patch)
tree5766b52635cea537d0e6c14722754fecbde8c714 /app-crypt/yapet/yapet-0.4-r1.ebuild
parentdev-python/eventlet: Remove useless ; at end of if block in src_install() (diff)
downloadsunrise-204f29480f16ec53e01743fb4b8a4e6cfe98f76e.tar.gz
sunrise-204f29480f16ec53e01743fb4b8a4e6cfe98f76e.tar.bz2
sunrise-204f29480f16ec53e01743fb4b8a4e6cfe98f76e.zip
app-crypt/yapet: Add ~amd64 into KEYWORDS. Fix QA messages from unpack() due to try to uncompress plain-text files. Switch to eapi-0 because src_prepare() and src_configure() added more code than with just src_unpack().Add ${patchset} in local scope
svn path=/sunrise/; revision=9049
Diffstat (limited to 'app-crypt/yapet/yapet-0.4-r1.ebuild')
-rw-r--r--app-crypt/yapet/yapet-0.4-r1.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/app-crypt/yapet/yapet-0.4-r1.ebuild b/app-crypt/yapet/yapet-0.4-r1.ebuild
index d8b2f412f..677c947de 100644
--- a/app-crypt/yapet/yapet-0.4-r1.ebuild
+++ b/app-crypt/yapet/yapet-0.4-r1.ebuild
@@ -2,11 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
-
AT_NOELIBTOOLIZE=yes
-inherit base eutils autotools
+inherit eutils autotools
DESCRIPTION="A curses (text) based password encryption tool"
HOMEPAGE="http://www.guengel.ch/myapps/yapet/"
@@ -18,7 +16,7 @@ SRC_URI="${URI_PREFIX}${P}.tar.bz2
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="nls"
RDEPEND="nls? ( virtual/libintl )
@@ -26,18 +24,21 @@ RDEPEND="nls? ( virtual/libintl )
>=dev-libs/openssl-0.9.7"
DEPEND="${RDEPEND}"
-PATCHES=(
- "${DISTDIR}/yapet_csv2yapet-${PV}.diff"
- "${DISTDIR}/yapet_cfgfile-${PV}.diff"
- "${DISTDIR}/yapet_vikeys-${PV}.diff"
-)
+src_unpack() {
+ local patchset=(
+ "${DISTDIR}/yapet_csv2yapet-${PV}.diff"
+ "${DISTDIR}/yapet_cfgfile-${PV}.diff"
+ "${DISTDIR}/yapet_vikeys-${PV}.diff"
+ )
-src_prepare() {
- base_src_prepare
- eautoreconf
-}
+ unpack "${P}.tar.bz2"
+ cd "${S}"
-src_configure() {
+ for x in ${patchset[@]}; do
+ epatch ${x}
+ done
+
+ eautoreconf
econf --enable-terminal-title \
--enable-csv2yapet \
--disable-source-doc \