summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Ostertag (rafi) <rafi@guengel.ch>2009-08-15 16:25:29 +0000
committerRafael Ostertag (rafi) <rafi@guengel.ch>2009-08-15 16:25:29 +0000
commitc831bec556a8d035312659787032287294a14af7 (patch)
tree41d4de34d43ae0680767178d83b3a9f68f512763 /app-crypt/yapet/yapet-0.4-r1.ebuild
parentdev-python/eventlet: Version bump (diff)
downloadsunrise-c831bec556a8d035312659787032287294a14af7.tar.gz
sunrise-c831bec556a8d035312659787032287294a14af7.tar.bz2
sunrise-c831bec556a8d035312659787032287294a14af7.zip
app-crypt/yapet: New Ebuild for bug 281028 thanks to chithead, jlec, ssuominen, Tommy [D], and whyscream
svn path=/sunrise/; revision=9014
Diffstat (limited to 'app-crypt/yapet/yapet-0.4-r1.ebuild')
-rw-r--r--app-crypt/yapet/yapet-0.4-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/yapet/yapet-0.4-r1.ebuild b/app-crypt/yapet/yapet-0.4-r1.ebuild
new file mode 100644
index 000000000..59fbb9d38
--- /dev/null
+++ b/app-crypt/yapet/yapet-0.4-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+AT_NOELIBTOOLIZE=yes
+
+inherit base eutils autotools
+
+DESCRIPTION="A curses (text) based password encryption tool"
+HOMEPAGE="http://www.guengel.ch/myapps/yapet/"
+URI_PREFIX="http://www.guengel.ch/myapps/yapet/downloads/"
+SRC_URI="${URI_PREFIX}${P}.tar.bz2
+ ${URI_PREFIX}patches/${PN}_csv2yapet-${PV}.diff
+ ${URI_PREFIX}patches/${PN}_cfgfile-${PV}.diff
+ ${URI_PREFIX}patches/${PN}_vikeys-${PV}.diff"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+RDEPEND=">=sys-libs/ncurses-5.6
+ >=dev-libs/openssl-0.9.7"
+DEPEND="nls? ( sys-devel/gettext )
+ ${RDEPEND}"
+
+PATCHES=(
+ "${DISTDIR}/yapet_csv2yapet-${PV}.diff"
+ "${DISTDIR}/yapet_cfgfile-${PV}.diff"
+ "${DISTDIR}/yapet_vikeys-${PV}.diff"
+)
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-terminal-title \
+ --enable-csv2yapet \
+ --disable-source-doc \
+ --disable-build-doc \
+ $(use_enable nls)
+}