summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2010-10-15 17:29:04 +0000
committerIan Stakenvicius <axs@gentoo.org>2010-10-15 17:29:04 +0000
commitea9d0bed1f3d7f8ff933ea13dfe85b5928dc20d7 (patch)
tree146339369ca6ef06fc8ece5922a5ab86b78836ee /app-misc
parentRevert "dev-vcs/tortoisehg: Version bump" (diff)
downloadsunrise-ea9d0bed1f3d7f8ff933ea13dfe85b5928dc20d7.tar.gz
sunrise-ea9d0bed1f3d7f8ff933ea13dfe85b5928dc20d7.tar.bz2
sunrise-ea9d0bed1f3d7f8ff933ea13dfe85b5928dc20d7.zip
new category: x11-apps
svn path=/sunrise/; revision=11431
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/genealogyj-bin/genealogyj-bin-2.4.3.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-misc/genealogyj-bin/genealogyj-bin-2.4.3.ebuild b/app-misc/genealogyj-bin/genealogyj-bin-2.4.3.ebuild
index a6a37b87c..b1da4be1c 100644
--- a/app-misc/genealogyj-bin/genealogyj-bin-2.4.3.ebuild
+++ b/app-misc/genealogyj-bin/genealogyj-bin-2.4.3.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit eutils
+inherit eutils java-utils-2
-DESCRIPTION="GenealogyJ is a viewer and editor for genealogic data and is written in Java"
+DESCRIPTION="A viewer and editor for genealogic data, written in Java"
HOMEPAGE="http://genj.sf.net/"
SRC_URI="mirror://sourceforge/genj/genj_app-${PV}.zip
skins? ( mirror://sourceforge/genj/genj_lnf-2.0.zip )
@@ -21,7 +21,7 @@ done
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="${IUSE} geoview skins"
DEPEND="app-arch/unzip"
@@ -43,17 +43,19 @@ src_compile() {
src_install() {
PROGRAM_DIR=/opt/${PN}
- insinto ${PROGRAM_DIR}
- exeinto ${PROGRAM_DIR}
+ doexe "${FILESDIR}/genealogyj"
+ insinto ${PROGRAM_DIR}
doins -r *.jar gedcom report help contrib doc lib
use skins && doins -r lnf
+
+ exeinto ${PROGRAM_DIR}
doexe run.sh
- # Necessary to be able to run it as a user:
- fperms a+rx ${PROGRAM_DIR}/run.sh
- into /opt
- dobin "${FILESDIR}/genealogyj"
+ java-pkg_regjar "${D}/${PROGRAM_DIR}"/*.jar
+
+ # Necessary to be able to run it as a user:
+ #fperms a+rx ${PROGRAM_DIR}/run.sh
}
pkg_postinst() {