summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené Neumann (Necoro) <gentoo@necoro.eu>2010-08-10 18:28:53 +0000
committerRené Neumann (Necoro) <gentoo@necoro.eu>2010-08-10 18:28:53 +0000
commit282a317a09b484ebde00086b384ab951fc0dfd02 (patch)
treedb70f20e216c482ccb545749d0daed794d6b7e5d /app-office/radicale
parentnet-im/ekg2: Version bump. (diff)
downloadsunrise-282a317a09b484ebde00086b384ab951fc0dfd02.tar.gz
sunrise-282a317a09b484ebde00086b384ab951fc0dfd02.tar.bz2
sunrise-282a317a09b484ebde00086b384ab951fc0dfd02.zip
app-office/radicale: New ebuild for bug #322811
svn path=/sunrise/; revision=11113
Diffstat (limited to 'app-office/radicale')
-rw-r--r--app-office/radicale/ChangeLog8
-rw-r--r--app-office/radicale/Manifest5
-rw-r--r--app-office/radicale/files/radicale.init.d26
-rw-r--r--app-office/radicale/metadata.xml6
-rw-r--r--app-office/radicale/radicale-0.4.ebuild38
5 files changed, 83 insertions, 0 deletions
diff --git a/app-office/radicale/ChangeLog b/app-office/radicale/ChangeLog
new file mode 100644
index 000000000..952a5694f
--- /dev/null
+++ b/app-office/radicale/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-office/radicale
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 10 Aug 2010; René Neumann (Necoro) <gentoo@necoro.eu>
+ +radicale-0.4.ebuild, +files/radicale.init.d, +metadata.xml:
+ New ebuild for bug #322811
+
diff --git a/app-office/radicale/Manifest b/app-office/radicale/Manifest
new file mode 100644
index 000000000..cf65af0b3
--- /dev/null
+++ b/app-office/radicale/Manifest
@@ -0,0 +1,5 @@
+AUX radicale.init.d 550 RMD160 f1f6aa919952b744900c781b8d6cd9283bc44534 SHA1 3c2043b9f2680b14969bd7f3727e3df85c7f9c48 SHA256 1b28de6c1bc2c6119eb654622713fdd2c16d89105940c6b55d2bc081fbb2fd2c
+DIST Radicale-0.4.tar.gz 22907 RMD160 ef477e226976f970949fe78184f181cd244442b8 SHA1 70af6c97840c5f890974a7e08bd34f0163157bd1 SHA256 0a20380e5c69b07ee02e439c9a21644da024c9016a9b3fb480c21b9cfb8d2035
+EBUILD radicale-0.4.ebuild 734 RMD160 c928c3f6c2c40d761f16ed404282daa0f356d40f SHA1 6776f363ab0ad356ee2a254777539464e092dc7e SHA256 0c4d2e991f54ff325420c56d0d310948bf70d784b1ce9c5a4aadf549e9680936
+MISC ChangeLog 270 RMD160 f2232ae3e8536a484e7e74dc5cdf43336f2a9870 SHA1 699598891c76176a7f93b4dbbb582c7bb9d61502 SHA256 cdb3c465e7cedcfcbb64ffbff2f9ee261838d289d2f50298fcd64b82502b9801
+MISC metadata.xml 229 RMD160 f0f6417bec31ce8baba6d476664f7210c8c84c98 SHA1 e5f94f5caadc6f843fc90bb7959570cd503676fd SHA256 3b08fca3c878bdfc4e7639f477dd542d55a4ab5dce39a475e82633071d13eb3f
diff --git a/app-office/radicale/files/radicale.init.d b/app-office/radicale/files/radicale.init.d
new file mode 100644
index 000000000..53beabb15
--- /dev/null
+++ b/app-office/radicale/files/radicale.init.d
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+PIDFILE=/var/run/radicale.pid
+
+depend() {
+ use net
+ need localmount
+}
+
+start() {
+ ebegin "Starting radicale"
+ start-stop-daemon --start --quiet --background \
+ --pidfile ${PIDFILE} --make-pidfile \
+ --exec /usr/bin/radicale -- --foreground
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping radicale"
+ start-stop-daemon --stop --quiet \
+ --pidfile ${PIDFILE}
+ eend $?
+}
diff --git a/app-office/radicale/metadata.xml b/app-office/radicale/metadata.xml
new file mode 100644
index 000000000..e6233b5dc
--- /dev/null
+++ b/app-office/radicale/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer><email>maintainer-wanted@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-office/radicale/radicale-0.4.ebuild b/app-office/radicale/radicale-0.4.ebuild
new file mode 100644
index 000000000..3afe8715d
--- /dev/null
+++ b/app-office/radicale/radicale-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS=1
+
+inherit distutils
+
+MY_P="${PN/r/R}-${PV}"
+
+DESCRIPTION="A simple CalDAV calendar server"
+HOMEPAGE="http://www.radicale.org/"
+SRC_URI="http://www.radicale.org/src/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ # init file
+ newinitd "${FILESDIR}"/radicale.init.d radicale || die
+
+ # config file
+ insinto /etc/${PN}
+ doins config || die
+}
+
+pkg_postinst() {
+ elog "If you want to use SSL with ${PN}, please check that you have"
+ elog "installed >=dev-lang/python-2.6[ssl]."
+}