summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAngelo D'Autilia (sYdRo) <sydro@salug.it>2009-12-12 00:37:33 +0000
committerAngelo D'Autilia (sYdRo) <sydro@salug.it>2009-12-12 00:37:33 +0000
commitf901b7207ed7eb3026a850d6834c74cd6d15b408 (patch)
tree2d3e51b4f0a6a86a6f1212ba53b8cd61dcbfb493 /app-portage/portage-hooks/portage-hooks-0.1.ebuild
parentnet-firewall/vuurmuur: Improved ebuild for bug 115697 (diff)
downloadsunrise-f901b7207ed7eb3026a850d6834c74cd6d15b408.tar.gz
sunrise-f901b7207ed7eb3026a850d6834c74cd6d15b408.tar.bz2
sunrise-f901b7207ed7eb3026a850d6834c74cd6d15b408.zip
app-portage/portage-hooks: New Ebuil for bug 258386, review by Tommy[D]
svn path=/sunrise/; revision=9710
Diffstat (limited to 'app-portage/portage-hooks/portage-hooks-0.1.ebuild')
-rw-r--r--app-portage/portage-hooks/portage-hooks-0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-portage/portage-hooks/portage-hooks-0.1.ebuild b/app-portage/portage-hooks/portage-hooks-0.1.ebuild
new file mode 100644
index 000000000..bc6cbeb09
--- /dev/null
+++ b/app-portage/portage-hooks/portage-hooks-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="System of hooks for portage"
+HOMEPAGE="http://www.salug.it/~sydro/progetti/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_install() {
+ insinto /etc/portage
+ doins "${FILESDIR}/portage-hooks" || die "Error copy portage-hooks into /etc/portage directory"
+}
+
+pkg_postinst() {
+ elog "You must create a directory in /etc/portage/hooks with ebuild phase name."
+ elog "Es. EBUILD_PHASE=preinst The directory should be /etc/portage/hooks/preinst.d"
+ elog "In each directory there are any numbered scripts: 10example 20example"
+ elog
+ elog "If you would use portage-hooks system you need to append the"
+ elog "following statement to your"
+ elog "/etc/portage/bashrc file:"
+ elog
+ elog "source /etc/portage/portage-hooks"
+ elog
+}